summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMelon Bread2021-05-10 16:15:00 -0400
committerMelon Bread2021-05-10 16:15:00 -0400
commit8b7f0264767c2f0560bb5263ed64d77d93f81165 (patch)
tree4a64fc642bb9c2f4ed6a808ff5fc7abdf5da3d77
downloadaur-8b7f0264767c2f0560bb5263ed64d77d93f81165.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3b65f97f71e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = imgbrd-grabber-appimage
+ pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
+ pkgver = 7.5.1
+ pkgrel = 1
+ url = https://github.com/Bionus/imgbrd-grabber
+ arch = x86_64
+ license = Apache
+ makedepends = p7zip
+ depends = hicolor-icon-theme
+ depends = zlib
+ depends = fuse
+ noextract = $_pkgname
+ options = !strip
+ source = https://github.com/Bionus/imgbrd-grabber/releases/download/v7.5.1/Grabber_v7.5.1-x86_64.AppImage
+ sha256sums = fd5349ea09125ed08751e880c7f979e461f5bac02d73747da1b1b899984bb8ca
+
+pkgname = imgbrd-grabber-appimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1810dea5d5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Rain Clark <rain AT melonbread DOT dev>
+
+pkgname=imgbrd-grabber-appimage
+pkgver=7.5.1
+pkgrel=1
+pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
+arch=('x86_64')
+url="https://github.com/Bionus/imgbrd-grabber"
+license=('Apache')
+depends=('hicolor-icon-theme' 'zlib' 'fuse')
+makedepends=('p7zip')
+
+_pkgname="Grabber_v$pkgver-$arch.AppImage"
+_upkgname=grabber
+
+noextract=('$_pkgname')
+options=('!strip')
+
+source=(https://github.com/Bionus/imgbrd-grabber/releases/download/v${pkgver}/${_pkgname})
+sha256sums=('fd5349ea09125ed08751e880c7f979e461f5bac02d73747da1b1b899984bb8ca')
+
+prepare() {
+ cd "${srcdir}"
+ 7z x "${srcdir}/$_pkgname" $_upkgname.desktop usr/share/icons/hicolor/128x128/apps/$_upkgname.png
+ sed -i "s/Exec=Grabber/Exec=\/usr\/bin\/$_upkgname/" $_upkgname.desktop
+}
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 "$_pkgname" "${pkgdir}/opt/$_upkgname/$_upkgname.AppImage"
+ install -Dm644 "$_upkgname.desktop" "${pkgdir}/usr/share/applications/$_upkgname.desktop"
+ install -Dm644 "usr/share/icons/hicolor/128x128/apps/$_upkgname.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/$_upkgname.png"
+ mkdir "${pkgdir}/usr/bin"
+ ln -s "/opt/$_upkgname/$_upkgname.AppImage" "${pkgdir}/usr/bin/$_upkgname"
+}
+