summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKen Swenson2020-02-28 22:44:33 -0500
committerKen Swenson2020-02-28 22:44:33 -0500
commit0e98cc23956e2fd087c8303cb550c04d58ab71b3 (patch)
tree1c000c8850c861fdfa5d20f0cd7298d57ed45f4d
parent49da08f83580bff6e9df9c4d525d9994c585d1a6 (diff)
downloadaur-0e98cc23956e2fd087c8303cb550c04d58ab71b3.tar.gz
upgpkg: imgbrd-grabber-git v7.2.1.r0.b042288c-1
Handle new submodules in PKGBUILD
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 28 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb083fc61f11..4885dee844c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imgbrd-grabber-git
pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
- pkgver = v7.1.1.r3.1254e59f
+ pkgver = v7.2.1.r0.b042288c
pkgrel = 1
url = https://github.com/Bionus/imgbrd-grabber
arch = i686
@@ -16,6 +16,12 @@ pkgbase = imgbrd-grabber-git
provides = imgbrd-grabber
conflicts = imgbrd-grabber
source = git+https://github.com/Bionus/imgbrd-grabber.git
+ source = git+https://github.com/LaurentGomila/qt-android-cmake.git
+ source = git+https://github.com/sakra/cotire.git
+ source = git+https://github.com/catchorg/Catch2.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = imgbrd-grabber-git
diff --git a/PKGBUILD b/PKGBUILD
index e12737734ba2..c0ba39a741aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Flat <flat@imo.uto.moe>
pkgname=imgbrd-grabber-git
-pkgver=v7.1.1.r3.1254e59f
+pkgver=v7.2.1.r0.b042288c
pkgrel=1
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('i686' 'x86_64')
@@ -10,8 +10,14 @@ depends=('qt5-multimedia' 'qt5-declarative' 'nodejs')
makedepends=('git' 'cmake' 'qt5-tools' 'npm')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/Bionus/imgbrd-grabber.git')
-md5sums=('SKIP')
+source=('git+https://github.com/Bionus/imgbrd-grabber.git'
+ 'git+https://github.com/LaurentGomila/qt-android-cmake.git'
+ 'git+https://github.com/sakra/cotire.git'
+ 'git+https://github.com/catchorg/Catch2.git')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
@@ -19,6 +25,18 @@ pkgver() {
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git config submodule.qt-android-cmake.url "$srcdir/qt-android-cmake"
+ git config submodule.qt-android-cmake.path "$srcdir/${pkgname%-git}/cmake/qt-android-cmake"
+ git config submodule.cotire.url "$srcdir/cotire"
+ git config submodule.cotire.path "$srcdir/${pkgname%-git}/cmake/cotire"
+ git config submodule.Catch2.url $srcdir/Catch2
+ git config submodule.Catch2.path "$srcdir/${pkgname%-git}/tests/src/vendor/catch"
+ git submodule update
+}
+
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"