summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2022-01-10 17:19:15 -0500
committerEthan Kerrick2022-01-10 17:19:15 -0500
commit666327662d045a2f35097a014a98ddb80c7185da (patch)
tree10f7de0ba5a63e0c31a24f1fba7cc858d5b4d476
parentc6ab72bc220d0833eec07ac22c3400f5279d0eec (diff)
downloadaur-666327662d045a2f35097a014a98ddb80c7185da.tar.gz
add submodules to sources
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4658f6526680..7ce35133f4e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imgbrd-grabber-git
pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
- pkgver = v7.6.2.r128.46db5730
- pkgrel = 1
+ pkgver = v7.7.1.r3.ce5dbf58
+ pkgrel = 2
url = https://github.com/Bionus/imgbrd-grabber
arch = i686
arch = x86_64
@@ -20,6 +20,12 @@ pkgbase = imgbrd-grabber-git
conflicts = imgbrd-grabber
source = git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop
source = Grabber.desktop
+ source = git+https://github.com/catchorg/Catch2.git
+ source = git+https://github.com/sakra/cotire.git
+ source = git+https://github.com/LaurentGomila/qt-android-cmake.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4cebf3abd757..8c35a94b2bf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Flat <flat@imo.uto.moe>
pkgname=imgbrd-grabber-git
-pkgver=v7.6.2.r128.46db5730
-pkgrel=1
+pkgver=v7.7.1.r3.ce5dbf58
+pkgrel=2
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('i686' 'x86_64')
url="https://github.com/Bionus/imgbrd-grabber"
@@ -11,8 +11,8 @@ makedepends=('git' 'cmake' 'qt5-tools' 'npm')
optdepends=('openssl: used for HTTPS sources')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop' 'Grabber.desktop')
-md5sums=('SKIP' 'SKIP')
+source=('git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop' 'Grabber.desktop' 'git+https://github.com/catchorg/Catch2.git' 'git+https://github.com/sakra/cotire.git' 'git+https://github.com/LaurentGomila/qt-android-cmake.git')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
@@ -22,7 +22,11 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.catch.url "$srcdir/Catch2"
+ git config submodule.qt-android-cmake.url "$srcdir/qt-android-cmake"
+ git config submodule.cotire.url "$srcdir/cotire"
+ git submodule update
}
build() {