summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2021-11-17 21:53:16 -0500
committerEthan Kerrick2021-11-17 21:53:16 -0500
commitc6ab72bc220d0833eec07ac22c3400f5279d0eec (patch)
tree3226e8276f178a4030ffc6de110c7d5c5d2a6efb
parentac10fe1c08ee465403714d1502b041d1d385658b (diff)
downloadaur-c6ab72bc220d0833eec07ac22c3400f5279d0eec.tar.gz
removed patch, and add desktop file
-rw-r--r--.SRCINFO4
-rw-r--r--Grabber.desktop28
-rw-r--r--PKGBUILD7
-rw-r--r--variableToString-instantiation-grabber.patch14
4 files changed, 34 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 502af7329616..4658f6526680 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = imgbrd-grabber-git
pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
- pkgver = v7.6.2.r92.d6fb4bd7
+ pkgver = v7.6.2.r128.46db5730
pkgrel = 1
url = https://github.com/Bionus/imgbrd-grabber
arch = i686
@@ -19,7 +19,7 @@ pkgbase = imgbrd-grabber-git
provides = imgbrd-grabber
conflicts = imgbrd-grabber
source = git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop
- source = variableToString-instantiation-grabber.patch
+ source = Grabber.desktop
md5sums = SKIP
md5sums = SKIP
diff --git a/Grabber.desktop b/Grabber.desktop
new file mode 100644
index 000000000000..87036553aa86
--- /dev/null
+++ b/Grabber.desktop
@@ -0,0 +1,28 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=1.0
+
+# The name of the application
+Name=Grabber
+
+# A comment which can/will be used as a tooltip
+Comment=a Very customizable imageboard/booru downloader
+
+# The path to the folder in which the executable is run
+Path=/usr/bin
+
+# The executable of the application, possibly with arguments.
+Exec=Grabber
+
+# The name of the icon that will be used to display this entry
+Icon=Grabber
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+
+# Describes the categories in which this entry should be shown
+Categories=Graphics;
diff --git a/PKGBUILD b/PKGBUILD
index cb1deeb6ac95..4cebf3abd757 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Flat <flat@imo.uto.moe>
pkgname=imgbrd-grabber-git
-pkgver=v7.6.2.r92.d6fb4bd7
+pkgver=v7.6.2.r128.46db5730
pkgrel=1
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ makedepends=('git' 'cmake' 'qt5-tools' 'npm')
optdepends=('openssl: used for HTTPS sources')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop' 'variableToString-instantiation-grabber.patch')
+source=('git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop' 'Grabber.desktop')
md5sums=('SKIP' 'SKIP')
@@ -22,7 +22,6 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- patch -p1 -d src/ < ../variableToString-instantiation-grabber.patch
git submodule update --init --recursive
}
@@ -39,5 +38,7 @@ build() {
package() {
cd "$srcdir/build"
make DESTDIR="$pkgdir/" install
+ install -Dm644 "$srcdir/${pkgname%-git}/src/gui/resources/images/icon.png" "$pkgdir/usr/share/pixmaps/Grabber.png"
+ install -Dm644 "$srcdir/Grabber.desktop" "$pkgdir/usr/share/applications/Grabber.desktop"
touch "$pkgdir/usr/share/Grabber/settings.ini"
}
diff --git a/variableToString-instantiation-grabber.patch b/variableToString-instantiation-grabber.patch
deleted file mode 100644
index 2ed3bc32b831..000000000000
--- a/variableToString-instantiation-grabber.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/lib/src/filename/filename-execution-visitor.cpp b/src/lib/src/filename/filename-execution-visitor.cpp
-index c0c666c1..6b2d338c 100644
---- a/lib/src/filename/filename-execution-visitor.cpp
-+++ b/lib/src/filename/filename-execution-visitor.cpp
-@@ -213,6 +213,9 @@ QString FilenameExecutionVisitor::variableToString(const QString &name, T val, c
- : QString::number(val);
- }
-
-+template
-+QString FilenameExecutionVisitor::variableToString<int>(const QString &name, int val, const QMap<QString, QString> &options);
-+
- QString FilenameExecutionVisitor::variableToString(const QString &name, QStringList val, const QMap<QString, QString> &options)
- {
- // Count