summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-25 20:10:46 +0300
committerorhun2020-10-25 20:10:46 +0300
commit986e637b96e31ad283d5fff78180bac292e8eda2 (patch)
tree950707db1a7a6e020e80de89da4cd881b684121f
parent6f4b94113ccf52704ab4ed1e46c5d2ff4230ed96 (diff)
downloadaur-986e637b96e31ad283d5fff78180bac292e8eda2.tar.gz
upgpkg: imgcat 1.0.2-1
upstream release Append new package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 31 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbe53937c729..e9ee5c1be005 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by makepkg 5.0.0
-# Tue Mar 1 18:46:05 UTC 2016
pkgbase = imgcat
- pkgdesc = bash script for iTerm2 v2.9+ that allows images to be displayed in a terminal session
- pkgver = 2.9.20160206
+ pkgdesc = Output images as RGB ANSI graphics on the terminal
+ pkgver = 1.0.2
pkgrel = 1
- url = https://iterm2.com/images.html
- arch = i686
+ url = https://github.com/trashhalo/imgcat
arch = x86_64
- license = gpl
- depends = bash
- source = https://raw.githubusercontent.com/gnachman/iTerm2/v2.9.20160206/tests/imgcat
- md5sums = 2bd63c22c24b77251a110ed0f0fe527a
+ license = MIT
+ makedepends = go
+ source = imgcat-1.0.2.tar.gz::https://github.com/trashhalo/imgcat/archive/v1.0.2.tar.gz
+ sha512sums = 9b49778325f7c8ab69c51d9499f0e72036bc701a4067338855e4433f9ddcc9fcccb4d7b62e1cc3bdd652af2a382830410d9db90e1642b2aaf58eca93f272b7ea
pkgname = imgcat
diff --git a/PKGBUILD b/PKGBUILD
index 4ba78b425db3..b9d8be4146f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,30 @@
-# Maintainer: sweetpea-aur@tentacle.net
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
pkgname=imgcat
-pkgver=2.9.20160206
+pkgdesc="Output images as RGB ANSI graphics on the terminal"
+pkgver=1.0.2
pkgrel=1
-pkgdesc="bash script for iTerm2 v2.9+ that allows images to be displayed in a terminal session"
-arch=('i686' 'x86_64')
-url="https://iterm2.com/images.html"
-depends=('bash')
-license=('gpl')
-source=("https://raw.githubusercontent.com/gnachman/iTerm2/v${pkgver}/tests/${pkgname}")
-md5sums=('2bd63c22c24b77251a110ed0f0fe527a')
+arch=('x86_64')
+url="https://github.com/trashhalo/imgcat"
+license=('MIT')
+makedepends=('go')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('9b49778325f7c8ab69c51d9499f0e72036bc701a4067338855e4433f9ddcc9fcccb4d7b62e1cc3bdd652af2a382830410d9db90e1642b2aaf58eca93f272b7ea')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go get -d ./...
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o "$pkgname" .
+}
package() {
-cd $srcdir
-install -Dm755 imgcat $pkgdir/usr/bin/imgcat
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}