summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Joost2020-12-16 08:52:17 +0100
committerPieter Joost2020-12-16 08:52:17 +0100
commit8b1c1a38496327a7bfa36acb605b9da600722121 (patch)
treeefbdde37f0c7116f3850459c252a6099d58af4b0
downloadaur-8b1c1a38496327a7bfa36acb605b9da600722121.tar.gz
initial release 1.0.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ed8d9c27201
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = imgdiff
+ pkgdesc = Faster than the fastest in the world pixel-by-pixel image difference tool.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/n7olkachev/imgdiff
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = https://github.com/n7olkachev/imgdiff/archive/v1.0.0.tar.gz
+ md5sums = a8f7958f42ed207811a65d31b2177c92
+
+pkgname = imgdiff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d4d21006f29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pieter Joost <pj@born2code.net>
+pkgname=imgdiff
+pkgver=1.0.0
+pkgrel=1
+url="https://github.com/n7olkachev/${pkgname}"
+pkgdesc="Faster than the fastest in the world pixel-by-pixel image difference tool."
+arch=('i686' 'x86_64')
+license=('MIT')
+makedepends=(
+ 'go'
+ 'git'
+)
+source=("${url}/archive/v${pkgver}.tar.gz")
+md5sums=(
+ 'a8f7958f42ed207811a65d31b2177c92'
+)
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ go build \
+ -o $pkgname \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
+ ./cmd
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}