summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Callear2017-12-18 16:44:33 -0700
committerZach Callear2017-12-18 16:44:33 -0700
commit4fdf51ef082f4239ecc98bb71c98bedfbd6f94b8 (patch)
tree970633dbb6486410d11c2c49510024a70377b602
parentb77e8e037985e211e0de0eb529e669627aeaebfb (diff)
downloadaur-4fdf51ef082f4239ecc98bb71c98bedfbd6f94b8.tar.gz
Use libmagick6
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3be027dd07d8..45a15180cce2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
_pkgname=imgmin
pkgname=$_pkgname-git
-pkgver=1.1.r11.gaadce1a
+pkgver=1.1.r17.g3451031
pkgrel=1
pkgdesc="Automated lossy JPEG optimization"
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url="https://github.com/rflynn/imgmin"
license=('MIT')
depends=('imagemagick')
-makedepends=('git')
+makedepends=('git libmagick6')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+$url.git")
@@ -24,6 +24,9 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ # Use libmagick6 with MagickWand-config.
+ sed -i 's~\($(MAGICK_CONFIG\)~PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig \1~g' src/Makefile.am src/apache2/Makefile.am
+
#fix build issue with Apache module on some systems
sed -i 's/\(MAGICK_CONFIG.*\?xargs\)/\1|sed "s\/-fopenmp\\s\/\/g"/' src/apache2/Makefile.am