summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorozgursarier2018-04-24 22:10:25 +0300
committerozgursarier2018-04-24 22:10:25 +0300
commitb95e48cbb974ed9527daef871261adb0ff9a4497 (patch)
tree466e89f285746b08e0ac0537b46119634d257b92
downloadaur-b95e48cbb974ed9527daef871261adb0ff9a4497.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e0b77ef6362
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Apr 24 18:58:43 UTC 2018
+pkgbase = imgpatchtools-git
+ pkgdesc = Patch img files with system.patch.dat, like OTA zip on PC
+ pkgver = 0.3.r5.g64a745d
+ pkgrel = 1
+ url = https://github.com/erfanoabdi/imgpatchtools
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = zlib
+ depends = bzip2
+ depends = openssl
+ provides = imgpatchtools
+ source = git+https://github.com/erfanoabdi/imgpatchtools.git
+ md5sums = SKIP
+
+pkgname = imgpatchtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7031ef42bbb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=imgpatchtools
+pkgver=0.3.r5.g64a745d
+pkgrel=1
+pkgdesc="Patch img files with system.patch.dat, like OTA zip on PC"
+arch=('any')
+url="https://github.com/erfanoabdi/imgpatchtools"
+license=('GPL')
+depends=('zlib' 'bzip2' 'openssl')
+makedepends=('git')
+source=("git+https://github.com/erfanoabdi/$pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/$pkgname"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/$pkgname"
+ make all
+}
+
+package() {
+ cd "${srcdir}/$pkgname"
+ install -d "${pkgdir}/usr/bin/"
+ install -Dm0755 ./bin/* "${pkgdir}/usr/bin/"
+}