summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerman Lashevich2023-10-13 20:35:24 +0200
committerGerman Lashevich2023-10-13 20:35:24 +0200
commitc29f7e52259a941f0ff7b8b33306be3b82114f74 (patch)
tree333e2dee7ccb52ae6bd5b8d0556bc16f6a7b8eb6
downloadaur-c29f7e52259a941f0ff7b8b33306be3b82114f74.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b88db44a711
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = imgpkg-bin
+ pkgdesc = Package, distribute, and relocate your Kubernetes configuration and dependent OCI images as one OCI artifact: a bundle
+ pkgver = 0.38.0
+ pkgrel = 1
+ url = https://carvel.dev/imgpkg
+ arch = x86_64
+ arch = aarch64
+ license = Apache
+ provides = imgpkg
+ conflicts = imgpkg
+ conflicts = imgpkg-bin
+ conflicts = imgpkg-git
+ source_x86_64 = imgpkg-v0.38.0::https://github.com/carvel-dev/imgpkg/releases/download/v0.38.0/imgpkg-linux-amd64
+ sha256sums_x86_64 = 3f272fc7eacb129a989b8f686ea59455ab7e65423192803c15d6affb963f86a9
+ source_aarch64 = imgpkg-v0.38.0::https://github.com/carvel-dev/imgpkg/releases/download/v0.38.0/imgpkg-linux-arm64
+ sha256sums_aarch64 = 975f013ac48007314a34aa2d575c09fb186db0918f446a5ef0905ec2730453ef
+
+pkgname = imgpkg-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b45b5b6d7d80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: German Lashevich <german.lashevich@gmail.com>
+
+pkgname=imgpkg-bin
+pkgdesc="Package, distribute, and relocate your Kubernetes configuration and dependent OCI images as one OCI artifact: a bundle"
+pkgver=0.38.0
+pkgrel=1
+url="https://carvel.dev/imgpkg"
+arch=(x86_64 aarch64)
+license=(Apache)
+provides=(imgpkg)
+conflicts=(imgpkg imgpkg-bin imgpkg-git)
+
+source_x86_64=(
+ imgpkg-v0.38.0::https://github.com/carvel-dev/imgpkg/releases/download/v0.38.0/imgpkg-linux-amd64
+)
+sha256sums_x86_64=(
+ 3f272fc7eacb129a989b8f686ea59455ab7e65423192803c15d6affb963f86a9
+)
+source_aarch64=(
+ imgpkg-v0.38.0::https://github.com/carvel-dev/imgpkg/releases/download/v0.38.0/imgpkg-linux-arm64
+)
+sha256sums_aarch64=(
+ 975f013ac48007314a34aa2d575c09fb186db0918f446a5ef0905ec2730453ef
+)
+package() {
+ install -Dm 755 "${srcdir}/imgpkg-v0.38.0" "${pkgdir}/usr/bin/imgpkg"
+}