summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornezumisama2015-06-14 18:09:06 +0200
committernezumisama2015-06-14 18:09:06 +0200
commit96284f2d2b466edb9e4cb4f7f90386a5c03a2fa3 (patch)
treee3579ae88a4a0c48660aee1450c11665cb4a04c9
downloadaur-96284f2d2b466edb9e4cb4f7f90386a5c03a2fa3.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
-rw-r--r--make_it_work.patch23
-rw-r--r--python27.patch27
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21bc37f18150
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = imgseek
+ pkgdesc = a photo collection manager and viewer with content-based search and many other features
+ pkgver = 0.8.6
+ pkgrel = 9
+ url = http://www.imgseek.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pyqt3
+ depends = imagemagick
+ depends = python-imaging
+ source = http://downloads.sourceforge.net/sourceforge/imgseek/imgSeek-0.8.6.tar.bz2
+ source = python27.patch
+ source = make_it_work.patch
+ md5sums = 4b311475b51be649deb45afd6a12eaa2
+ md5sums = 18757ccbd513081228e993d6221060c1
+ md5sums = efab62e2f1b21196060e07293fe2dc1c
+
+pkgname = imgseek
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..583df0dbce47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Robert Emil Berge <robert@rebi.no>
+# Maintainer: AppleBloom <rat.o.drat@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=imgseek
+pkgver=0.8.6
+pkgrel=9
+pkgdesc="a photo collection manager and viewer with content-based search and many other features"
+url="http://www.imgseek.net"
+depends=('pyqt3' 'imagemagick' 'python-imaging')
+arch=('i686' 'x86_64')
+license=('GPL')
+source=("http://downloads.sourceforge.net/sourceforge/imgseek/imgSeek-$pkgver.tar.bz2"
+ "python27.patch"
+ "make_it_work.patch")
+md5sums=('4b311475b51be649deb45afd6a12eaa2'
+ '18757ccbd513081228e993d6221060c1'
+ 'efab62e2f1b21196060e07293fe2dc1c')
+
+_dir="imgSeek-$pkgver"
+
+prepare() {
+ cd "$_dir"
+ patch -p1 -i ../make_it_work.patch
+ patch -p1 -i ../python27.patch
+}
+
+build() {
+ cd "$_dir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$_dir"
+ python2 setup.py install --prefix="$pkgdir"/usr
+ cd "$pkgdir"/usr/lib/python2.7/site-packages/imgSeekLib
+ ln -s ImageDB.py ImgDB.py
+}
diff --git a/make_it_work.patch b/make_it_work.patch
new file mode 100644
index 000000000000..7795f5d57def
--- /dev/null
+++ b/make_it_work.patch
@@ -0,0 +1,23 @@
+diff -aur imgSeek-0.8.6.orig/imgSeekLib/haar.cpp imgSeek-0.8.6.new/imgSeekLib/haar.cpp
+--- imgSeek-0.8.6.orig/imgSeekLib/haar.cpp 2009-07-25 06:29:00.000000000 +0200
++++ imgSeek-0.8.6.new/imgSeekLib/haar.cpp 2009-07-25 06:30:42.000000000 +0200
+@@ -49,6 +49,7 @@
+ #include <math.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ /* imgSeek Includes */
+ #include "haar.h"
+diff -aur imgSeek-0.8.6.orig/setup.py imgSeek-0.8.6.new/setup.py
+--- imgSeek-0.8.6.orig/setup.py 2009-07-25 06:29:00.000000000 +0200
++++ imgSeek-0.8.6.new/setup.py 2009-07-25 06:31:25.000000000 +0200
+@@ -2,7 +2,7 @@
+
+ #############################[ Parameters you should change if install failed ]#########################################
+ # qtdir should point to the directory where QT is installed. (Inside this dir you should have a lib and include dir)
+-qtdir=["/usr/share/qt3/"] # ["/usr/qt/3/"] if you have a Gentoo system
++qtdir=["/opt/qt/"] # ["/usr/qt/3/"] if you have a Gentoo system
+
+ # python_dir should point to the directory where Python header files may be found.. (Inside this dir you should have a Python.h)
+ python_dir="/usr/include/python"
diff --git a/python27.patch b/python27.patch
new file mode 100644
index 000000000000..73d04fb82345
--- /dev/null
+++ b/python27.patch
@@ -0,0 +1,27 @@
+diff -Naur imgSeek-0.8.6.orig/imgSeek imgSeek-0.8.6.new/imgSeek
+--- imgSeek-0.8.6.orig/imgSeek 2009-10-18 18:14:05.000000000 +0200
++++ imgSeek-0.8.6.new/imgSeek 2010-10-16 21:30:33.000000000 +0200
+@@ -1,4 +1,4 @@
+-#! /usr/bin/env python
++#! /usr/bin/env python2
+ """
+ /***************************************************************************
+ imgSeek
+diff -Naur imgSeek-0.8.6.orig/setup-magick.py imgSeek-0.8.6.new/setup-magick.py
+--- imgSeek-0.8.6.orig/setup-magick.py 2009-10-18 18:14:05.000000000 +0200
++++ imgSeek-0.8.6.new/setup-magick.py 2010-10-16 21:30:16.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ #############################[ Parameters you should change if install failed ]#########################################
+ # qtdir should point to the directory where QT is installed. (Inside this dir you should have a lib and include dir)
+diff -Naur imgSeek-0.8.6.orig/setup.py imgSeek-0.8.6.new/setup.py
+--- imgSeek-0.8.6.orig/setup.py 2010-10-16 21:46:31.000000000 +0200
++++ imgSeek-0.8.6.new/setup.py 2010-10-16 21:46:40.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ #############################[ Parameters you should change if install failed ]#########################################
+ # qtdir should point to the directory where QT is installed. (Inside this dir you should have a lib and include dir)