summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSantiago Lo Coco2023-09-04 19:10:20 +0000
committerSantiago Lo Coco2023-09-04 19:10:20 +0000
commit622001739b27370de5ba30fe04fa404d8d97ec11 (patch)
tree9ed1d40fce36ed800e101d3864196a33619a56a0
parent3d6f43d492df5ea79af459390879346d87785784 (diff)
downloadaur-imgur.sh.tar.gz
Fix bug
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 624fabdf0b39..9fcf8d5b49b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = imgur.sh
- pkgdesc = An Imgur uploader bash script
+ pkgdesc = Bart's Imgur uploader bash script.
pkgver = 10.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/tremby/imgur.sh
arch = any
- license = custom:PublicDomain
+ license = Unlicense
depends = curl
optdepends = xsel: copy the URL to clipboard (or xclip)
optdepends = xclip: copy the URL to clipboard (or xsel)
- conflicts = imgurbash
- replaces = imgurbash
source = https://github.com/tremby/imgur.sh/archive/v10.1.tar.gz
sha256sums = 7cff3c68377ab0783619ee96bde4b73ed9032b1ce8f9164462f6e6718f69f814
diff --git a/PKGBUILD b/PKGBUILD
index d0320b5c3910..674b48287e5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,21 @@
-# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
-# Contributor: David Trail <david@vaunt.eu>
-# Contributor: Jan Stępień <jstepien@users.sourceforge.net>
+# Maintainer: Santiago Lo Coco <mail at slococo dot com dot ar>
pkgname=imgur.sh
pkgver=10.1
-pkgrel=1
-pkgdesc="An Imgur uploader bash script"
+pkgrel=2
+pkgdesc="Bart's Imgur uploader bash script."
arch=('any')
url="https://github.com/tremby/imgur.sh"
-license=('custom:PublicDomain')
+license=('Unlicense')
depends=('curl')
optdepends=('xsel: copy the URL to clipboard (or xclip)'
'xclip: copy the URL to clipboard (or xsel)')
-conflicts=('imgurbash')
-replaces=('imgurbash')
source=("https://github.com/tremby/imgur.sh/archive/v${pkgver}.tar.gz")
sha256sums=('7cff3c68377ab0783619ee96bde4b73ed9032b1ce8f9164462f6e6718f69f814')
package() {
cd "${pkgname}-${pkgver}"
- install -D -m 0755 imgur.sh "${pkgdir}/usr/bin/imgur.sh"
-
- install -D -m 0644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 imgur.sh "${pkgdir}/usr/bin/imgur.sh"
+ install -Dm644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: