summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRamon2016-04-04 21:00:42 +0200
committerRamon2016-04-04 21:00:42 +0200
commitebe9834c82acd2abc58ce9d7d1c3b1c1789d730e (patch)
tree9bcb3df3041199b61efc835cb4ba9098fab0600f
downloadaur-ebe9834c82acd2abc58ce9d7d1c3b1c1789d730e.tar.gz
Added imgurbash2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc88b5304f8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = imgurbash2
+ pkgdesc = A shell script that uploads images to imgur.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ram-on/imgurbash2
+ arch = any
+ license = MIT
+ depends = curl
+ optdepends = xsel: automatically putting the URL on the X selection for easy pasting
+ optdepends = xclip: an alternative to xsel
+ source = https://github.com/ram-on/imgurbash2/archive/1.0.tar.gz
+ sha256sums = 9c6a3fb61e995a9bafccc10e8196c009f467db039cc3791ebc33d75f331d0b48
+
+pkgname = imgurbash2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8364a8071910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Ramon <https://github.com/ram-on/imgurbash2>
+
+pkgname=imgurbash2
+pkgver=1.0
+pkgrel=1
+pkgdesc="A shell script that uploads images to imgur."
+arch=('any')
+url="https://github.com/ram-on/imgurbash2"
+license=('MIT')
+depends=('curl')
+optdepends=('xsel: automatically putting the URL on the X selection for easy pasting'
+ 'xclip: an alternative to xsel')
+source=('https://github.com/ram-on/imgurbash2/archive/1.0.tar.gz')
+sha256sums=('9c6a3fb61e995a9bafccc10e8196c009f467db039cc3791ebc33d75f331d0b48')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m 755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}