summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-12-13 23:02:11 +0300
committerCaleb Maclennan2021-12-13 23:02:11 +0300
commitbe8dd894b9fb6e4a9b79276d2f9bca6188ea5b2d (patch)
treea0a312aa28053b51a7f410b398530242a0fe7152
parentabb709e36c568e558c942eebdcffebd624ccc5fb (diff)
downloadaur-imgv.tar.gz
upgpkg: imgv 3.1.6-3
Disown
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1b1f29da468..cb99278e86de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = imgv
- pkgdesc = a feature rich image viewer including a GUI
+ pkgdesc = A feature rich image viewer including a GUI
pkgver = 3.1.6
- pkgrel = 2
+ pkgrel = 3
url = http://imgv.sourceforge.net/
arch = any
license = GPL
makedepends = dos2unix
+ depends = python
depends = python-pygame
depends = python-pillow
source = http://downloads.sourceforge.net/imgv/imgv-3.1.6-src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index d6fe1e2edec3..0bf53a8a7581 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer:
+# Contributor: Caleb Maclennan <caleb@alerque.com>
# Contributor: Eric Belanger <belanger@astro.umontreal.ca>
# Contributor: Nathan Owe <ndowens04+AUR @ gmail.com>
pkgname=imgv
pkgver=3.1.6
-pkgrel=2
-pkgdesc="a feature rich image viewer including a GUI"
-url="http://imgv.sourceforge.net/"
+pkgrel=3
+pkgdesc='A feature rich image viewer including a GUI'
+url='http://imgv.sourceforge.net/'
license=(GPL)
arch=(any)
-depends=(python-pygame
+depends=(python
+ python-pygame
python-pillow)
makedepends=(dos2unix)
_archive="$pkgname-$pkgver"
@@ -21,17 +23,17 @@ sha256sums=('7dd9db8d68f772e44acb9d8e8a81fdbe346644b6834cb30aad6a06b3fec99cb3'
'f2be0d9ffe6e349b72ded3519201db2684762ac9291bc9a02d94b932edcb1748')
build() {
- cd "$_archive"
- dos2unix *.py data/{imgv.conf,playlists}
- sed -i 's/#\s*$//g' *.py
- sed -i 's|COLOR|#COLOR|g' "data/imgv.conf"
- sed -i 's|CACHE_DIRS|#CACHE_DIRS|g' "gl.py"
+ cd "$_archive"
+ dos2unix *.py data/{imgv.conf,playlists}
+ sed -i 's/#\s*$//g' *.py
+ sed -i 's|COLOR|#COLOR|g' "data/imgv.conf"
+ sed -i 's|CACHE_DIRS|#CACHE_DIRS|g' "gl.py"
}
package() {
- cd "$_archive"
- install -d "$pkgdir/usr/share/imgv"
- cp -r * "$pkgdir/usr/share/imgv/"
- install -Dm0755 ../imgv.profile "$pkgdir/etc/profile.d/imgv.sh"
- install -Dm0755 ../imgv.sh "$pkgdir/usr/bin/imgv"
+ install -Dm0755 imgv.profile "$pkgdir/etc/profile.d/imgv.sh"
+ install -Dm0755 imgv.sh "$pkgdir/usr/bin/imgv"
+ cd "$_archive"
+ install -d "$pkgdir/usr/share/imgv"
+ cp -r * "$pkgdir/usr/share/imgv/"
}