summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2021-11-28 16:17:23 +0100
committerKokaKiwi2021-11-28 16:17:23 +0100
commit10acc6ebe76d6386bbe769b5e997c17a873472b5 (patch)
treebdaa948f1219e89296c019c85cb05f1eeee637c2
parentb7631c58d8dacc1cd82cbc2f93e21cb4fffee970 (diff)
downloadaur-10acc6ebe76d6386bbe769b5e997c17a873472b5.tar.gz
Update: 1.11.0
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Fix-crash-on-pattern-load-319.patch32
-rw-r--r--0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch54
-rw-r--r--0003-Fix-infinite-loop-on-signal-handling.patch25
-rw-r--r--PKGBUILD31
5 files changed, 11 insertions, 151 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27d1b5d31405..2b464d7428b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imhex
pkgdesc = A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM
- pkgver = 1.10.1
- pkgrel = 3
+ pkgver = 1.11.0
+ pkgrel = 1
url = https://github.com/WerWolv/ImHex
arch = x86_64
license = GPL2
@@ -22,33 +22,21 @@ pkgbase = imhex
depends = hicolor-icon-theme
depends = yara
depends = fmt
- source = imhex::git+https://github.com/WerWolv/ImHex.git#tag=v1.10.1
+ source = imhex::git+https://github.com/WerWolv/ImHex.git#tag=v1.11.0
source = nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git
- source = git+https://git.sr.ht/~danyspin97/xdgpp
+ source = xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp
source = imhex.desktop
- source = 0001-Fix-crash-on-pattern-load-319.patch
- source = 0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch
- source = 0003-Fix-infinite-loop-on-signal-handling.patch
cksums = SKIP
cksums = SKIP
cksums = SKIP
cksums = 4178124713
- cksums = 3591955572
- cksums = 35583119
- cksums = 1275958398
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 72525512a241589cecd6141f32ad36cbe1b5b6f2629dd8ead0e37812321bdde6
- sha256sums = cbe6a0f3623503be2c57905a2ed405ae3001ff5d8a8a708492f488f89672726c
- sha256sums = ba9794ebef4cec1085fe597f6b6e997e85ca9d839b084722729c7471d1117383
- sha256sums = 43a3ad9a9bc05382dde3da52d6f065f0c770457e47629eb0363eb6968fa317c4
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = 7b2d029de385fdc2536f57a4364add9752b9a5dc31df501e07bff1fd69fdd1de2afa19a5ac5a4c87fbf21c5d87cc96d3fe30d58825c050f5a7d25f6d85d08efc
- b2sums = 761635626e86b05bb03584219ef38e12abec1d2ef9dc78453ae0304fcbedbaa7c8f4859e5db8b89e08104bc94bcdd10d22de318628725cb8a0bde099f9a8ea25
- b2sums = b83335ebf63db82605aac11b26fe87a09db8bd6b80d780bda168c10df6669c31554b6919c53b46db664a3f6f0748d220d007042fb7b2c20743581c6b64217c90
- b2sums = 8ffcb4fe81d5290a53d95498ae64c18f158fc4312140d6ae23bd802ee5346de477c4c9fa2adc0db039dd1c2733d8268294dcee82c81066aac8d4e3018a6607dd
pkgname = imhex
diff --git a/0001-Fix-crash-on-pattern-load-319.patch b/0001-Fix-crash-on-pattern-load-319.patch
deleted file mode 100644
index 0abbcb49f6ef..000000000000
--- a/0001-Fix-crash-on-pattern-load-319.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 655a1d4f170fff1689ac3dcdbda6c79ff1c85409 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Anton=20=C3=84lgmyr?= <anton@algmyr.se>
-Date: Sat, 9 Oct 2021 17:08:45 +0200
-Subject: [PATCH 1/3] Fix crash on pattern load (#319)
-
----
- source/views/view_pattern_editor.cpp | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/source/views/view_pattern_editor.cpp b/source/views/view_pattern_editor.cpp
-index 2608679..734b94f 100644
---- a/source/views/view_pattern_editor.cpp
-+++ b/source/views/view_pattern_editor.cpp
-@@ -191,6 +191,8 @@ namespace hex {
- this->m_possiblePatternFiles.clear();
-
- for (auto &imhexPath : hex::getPath(ImHexPath::Patterns)) {
-+ if (!fs::exists(imhexPath)) continue;
-+
- for (auto &entry: fs::recursive_directory_iterator(imhexPath)) {
- if (entry.is_regular_file() && entry.path().extension() == ".hexpat") {
- this->m_possiblePatternFiles.push_back(entry.path());
-@@ -417,4 +419,4 @@ namespace hex {
-
- }
-
--}
-\ No newline at end of file
-+}
---
-2.33.1
-
diff --git a/0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch b/0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch
deleted file mode 100644
index bf04ee774123..000000000000
--- a/0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 6a1d0988d3c3bc9f135915542c37f953c0c262eb Mon Sep 17 00:00:00 2001
-From: WerWolv <werwolv98@gmail.com>
-Date: Mon, 11 Oct 2021 20:59:14 +0200
-Subject: [PATCH 2/3] patterns: Limit number of characters displayed in a
- string pattern
-
----
- .../hex/pattern_language/pattern_data.hpp | 16 ++++++++++------
- 1 file changed, 10 insertions(+), 6 deletions(-)
-
-diff --git a/plugins/libimhex/include/hex/pattern_language/pattern_data.hpp b/plugins/libimhex/include/hex/pattern_language/pattern_data.hpp
-index fdcc8b0..24cac33 100644
---- a/plugins/libimhex/include/hex/pattern_language/pattern_data.hpp
-+++ b/plugins/libimhex/include/hex/pattern_language/pattern_data.hpp
-@@ -598,10 +598,12 @@ namespace hex::pl {
- }
-
- void createEntry(prv::Provider* &provider) override {
-- std::string buffer(this->getSize(), 0x00);
-- provider->read(this->getOffset(), buffer.data(), this->getSize());
-+ auto size = std::min<size_t>(this->getSize(), 0x7F);
-+ std::string buffer(size, 0x00);
-
-- this->createDefaultEntry(hex::format("\"{0}\"", makeDisplayable(buffer.data(), this->getSize()).c_str()), buffer);
-+ provider->read(this->getOffset(), buffer.data(), size);
-+
-+ this->createDefaultEntry(hex::format("\"{0}\" {1}", makeDisplayable(buffer.data(), this->getSize()), size > this->getSize() ? "(truncated)" : ""), buffer);
- }
-
- [[nodiscard]] std::string getFormattedName() const override {
-@@ -621,15 +623,17 @@ namespace hex::pl {
- }
-
- void createEntry(prv::Provider* &provider) override {
-- std::u16string buffer(this->getSize(), 0x00);
-- provider->read(this->getOffset(), buffer.data(), this->getSize());
-+ auto size = std::min<size_t>(this->getSize(), 0x100);
-+
-+ std::u16string buffer(size, 0x00);
-+ provider->read(this->getOffset(), buffer.data(), size);
-
- for (auto &c : buffer)
- c = hex::changeEndianess(c, 2, this->getEndian());
-
- auto utf8String = std::wstring_convert<std::codecvt_utf8_utf16<char16_t>, char16_t>{}.to_bytes(buffer);
-
-- this->createDefaultEntry(hex::format("\"{0}\"", utf8String), utf8String);
-+ this->createDefaultEntry(hex::format("\"{0}\" {1}", utf8String, size > this->getSize() ? "(truncated)" : ""), utf8String);
- }
-
- [[nodiscard]] std::string getFormattedName() const override {
---
-2.33.1
-
diff --git a/0003-Fix-infinite-loop-on-signal-handling.patch b/0003-Fix-infinite-loop-on-signal-handling.patch
deleted file mode 100644
index 9623fbf845e0..000000000000
--- a/0003-Fix-infinite-loop-on-signal-handling.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7d0a277dfd1be4b5ebcd7228acd122934e296f51 Mon Sep 17 00:00:00 2001
-From: KokaKiwi <kokakiwi+git@kokakiwi.net>
-Date: Tue, 9 Nov 2021 16:11:52 +0100
-Subject: [PATCH 3/3] Fix infinite loop on signal handling.
-
-Signed-off-by: KokaKiwi <kokakiwi+git@kokakiwi.net>
----
- source/window/window.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/source/window/window.cpp b/source/window/window.cpp
-index c8aa5fa..b546fa8 100644
---- a/source/window/window.cpp
-+++ b/source/window/window.cpp
-@@ -239,6 +239,7 @@ namespace hex {
-
-
- auto signalHandler = [](int signalNumber) {
-+ std::signal(signalNumber, nullptr);
- EventManager::post<EventAbnormalTermination>(signalNumber);
-
- std::raise(SIGABRT);
---
-2.33.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 1e03c11e93d4..5456177f1420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
-pkgver=1.10.1
-pkgrel=3
+pkgver=1.11.0
+pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://github.com/WerWolv/ImHex'
license=('GPL2')
@@ -15,32 +15,20 @@ depends=('glfw' 'capstone' 'mbedtls' 'libssh2'
makedepends=('git' 'cmake' 'glm' 'llvm' 'nlohmann-json' 'librsvg')
source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
"nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git"
- "git+https://git.sr.ht/~danyspin97/xdgpp"
- imhex.desktop
- 0001-Fix-crash-on-pattern-load-319.patch
- 0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch
- 0003-Fix-infinite-loop-on-signal-handling.patch)
+ "xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp"
+ imhex.desktop)
cksums=('SKIP'
'SKIP'
'SKIP'
- '4178124713'
- '3591955572'
- '35583119'
- '1275958398')
+ '4178124713')
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '72525512a241589cecd6141f32ad36cbe1b5b6f2629dd8ead0e37812321bdde6'
- 'cbe6a0f3623503be2c57905a2ed405ae3001ff5d8a8a708492f488f89672726c'
- 'ba9794ebef4cec1085fe597f6b6e997e85ca9d839b084722729c7471d1117383'
- '43a3ad9a9bc05382dde3da52d6f065f0c770457e47629eb0363eb6968fa317c4')
+ '72525512a241589cecd6141f32ad36cbe1b5b6f2629dd8ead0e37812321bdde6')
b2sums=('SKIP'
'SKIP'
'SKIP'
- '7b2d029de385fdc2536f57a4364add9752b9a5dc31df501e07bff1fd69fdd1de2afa19a5ac5a4c87fbf21c5d87cc96d3fe30d58825c050f5a7d25f6d85d08efc'
- '761635626e86b05bb03584219ef38e12abec1d2ef9dc78453ae0304fcbedbaa7c8f4859e5db8b89e08104bc94bcdd10d22de318628725cb8a0bde099f9a8ea25'
- 'b83335ebf63db82605aac11b26fe87a09db8bd6b80d780bda168c10df6669c31554b6919c53b46db664a3f6f0748d220d007042fb7b2c20743581c6b64217c90'
- '8ffcb4fe81d5290a53d95498ae64c18f158fc4312140d6ae23bd802ee5346de477c4c9fa2adc0db039dd1c2733d8268294dcee82c81066aac8d4e3018a6607dd')
+ '7b2d029de385fdc2536f57a4364add9752b9a5dc31df501e07bff1fd69fdd1de2afa19a5ac5a4c87fbf21c5d87cc96d3fe30d58825c050f5a7d25f6d85d08efc')
prepare() {
cd "$pkgname"
@@ -53,11 +41,6 @@ prepare() {
git config --remove-section submodule.external/$name
done
git submodule update
-
- git apply \
- "$srcdir/0001-Fix-crash-on-pattern-load-319.patch" \
- "$srcdir/0002-patterns-Limit-number-of-characters-displayed-in-a-s.patch" \
- "$srcdir/0003-Fix-infinite-loop-on-signal-handling.patch"
}
build() {