summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2022-08-14 16:03:54 +0200
committerKokaKiwi2022-08-14 16:03:54 +0200
commit643c6197852a44ee31630705e60a7075e184e37c (patch)
treecfab8048cc7b82ac6ab9d55ed1b9925e5d0a78e6
parenta3552fc0583c55568ee9a796c7fad3555dd01de0 (diff)
downloadaur-643c6197852a44ee31630705e60a7075e184e37c.tar.gz
Update: 1.21.0
-rw-r--r--.SRCINFO22
-rw-r--r--0001-makepkg-Fix-compiler-flags.patch35
-rw-r--r--0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch54
-rw-r--r--0002-fix-Deduplicate-resources-directories.patch12
-rw-r--r--PKGBUILD22
5 files changed, 63 insertions, 82 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77fa5c4aaccc..13dfb43921a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imhex
pkgdesc = A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM
- pkgver = 1.20.0
- pkgrel = 2
+ pkgver = 1.21.0
+ pkgrel = 1
url = https://imhex.werwolv.net
arch = x86_64
license = GPL2
@@ -24,13 +24,13 @@ pkgbase = imhex
depends = yara
optdepends = imhex-patterns-git: ImHex base patterns
options = !lto
- source = imhex::git+https://github.com/WerWolv/ImHex.git#tag=v1.20.0
+ source = imhex::git+https://github.com/WerWolv/ImHex.git#tag=v1.21.0
source = nativefiledialog::git+https://github.com/btzy/nativefiledialog-extended.git
source = xdgpp::git+https://git.sr.ht/~danyspin97/xdgpp
source = libromfs::git+https://github.com/WerWolv/libromfs
source = capstone::git+https://github.com/capstone-engine/capstone#branch=next
- source = pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v1.20.0
- source = 0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch
+ source = pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v1.21.0
+ source = 0001-makepkg-Fix-compiler-flags.patch
source = 0002-fix-Deduplicate-resources-directories.patch
cksums = SKIP
cksums = SKIP
@@ -38,23 +38,23 @@ pkgbase = imhex
cksums = SKIP
cksums = SKIP
cksums = SKIP
- cksums = 1164761330
- cksums = 1600868006
+ cksums = 545604144
+ cksums = 3160577462
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = ecc146f00787774d72581fa684064eb42598c0f0cc721b4d72c1d02324377107
- sha256sums = aaeb91e6de14b4f8d59834a44a9209bc2829553b7b11ede72112098a533384ae
+ sha256sums = ac4bf097441311abb860c423521eba2fa152194d9294b10ef403bbd8eb6105a1
+ sha256sums = 091a4824ceb3f1f5da5efc1ee6ac025b1ab9b56d07bd75bdb52fae71f7dec046
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = c1901108a6f558dc0e3a2695778f1dd633762c726962284de55eb1fd451ab325b4605b801d0dd3471c354e506a3e805c8147908b108a63982d5424baa71a38ce
- b2sums = 51be06849a16eec5180a7523c2c78ac39238cb85d7d0d048691c45d8e38236f96c2b07c735970d5e282ff401a2146fad0764c2d9fa1fcab529865615118d69b1
+ b2sums = e52df3fc4629151b2156f4d75b13b1d7ac7bff07cebb151da391a3982c71608f7797a03cff5c560263ac46f32843f08b23437c31f9ef729e2e4ccc2bdb826900
+ b2sums = 456edc844d9934be7fc7918ca15d82242df54563e400b6d58a20dd739793495834a9ac147517a2c88139926bef97f195849cd5a0b4b303cf452d4ef4317cb1af
pkgname = imhex
diff --git a/0001-makepkg-Fix-compiler-flags.patch b/0001-makepkg-Fix-compiler-flags.patch
new file mode 100644
index 000000000000..85bd9e001d54
--- /dev/null
+++ b/0001-makepkg-Fix-compiler-flags.patch
@@ -0,0 +1,35 @@
+From 138bc84483e616f24be943c17ba67dce52561e42 Mon Sep 17 00:00:00 2001
+From: KokaKiwi <kokakiwi+git@kokakiwi.net>
+Date: Mon, 8 Aug 2022 00:34:05 +0200
+Subject: [PATCH 1/2] makepkg: Fix compiler flags
+
+---
+ cmake/build_helpers.cmake | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/cmake/build_helpers.cmake b/cmake/build_helpers.cmake
+index 2a313888..8ae42bfc 100644
+--- a/cmake/build_helpers.cmake
++++ b/cmake/build_helpers.cmake
+@@ -384,10 +384,14 @@ function(downloadImHexPatternsFiles dest)
+ endfunction()
+
+ macro(setupCompilerWarnings target)
+- set(IMHEX_COMMON_FLAGS "-Wall -Wextra -Werror")
+- set(IMHEX_C_FLAGS "${IMHEX_COMMON_FLAGS} -Wno-restrict -Wno-stringop-overread")
++ set(IMHEX_COMMON_FLAGS "")
++ set(IMHEX_C_FLAGS "${IMHEX_COMMON_FLAGS}")
++
++ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
++ set(IMHEX_C_FLAGS "${IMHEX_C_FLAGS} -Wno-restrict -Wno-stringop-overread")
++ endif()
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${IMHEX_C_FLAGS}")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${IMHEX_C_FLAGS}")
+ set(CMAKE_OBJC_FLAGS "${CMAKE_OBJC_FLAGS} ${IMHEX_COMMON_FLAGS}")
+-endmacro()
+\ No newline at end of file
++endmacro()
+--
+2.37.2
+
diff --git a/0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch b/0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch
deleted file mode 100644
index d2faa77953fa..000000000000
--- a/0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 47681afb2edfa1abf79ed0d6d404f872be706e3d Mon Sep 17 00:00:00 2001
-From: KokaKiwi <kokakiwi+git@kokakiwi.net>
-Date: Mon, 8 Aug 2022 00:34:05 +0200
-Subject: [PATCH 1/2] makepkg: Fix compiler verification and compiler flags
-
----
- cmake/build_helpers.cmake | 17 ++++++++++-------
- 1 file changed, 10 insertions(+), 7 deletions(-)
-
-diff --git a/cmake/build_helpers.cmake b/cmake/build_helpers.cmake
-index b7f8ff51..f38bf4b6 100644
---- a/cmake/build_helpers.cmake
-+++ b/cmake/build_helpers.cmake
-@@ -322,15 +322,14 @@ function(detectBadClone)
- endforeach ()
- endfunction()
-
--set(IMHEX_REQUIRED_COMPILER "GNU")
--set(IMHEX_MIN_COMPILER_VERSION "12.0.0")
-+set(IMHEX_MIN_GCC_VERSION "12.0.0")
- function(verifyCompiler)
- if (IMHEX_IGNORE_BAD_COMPILER)
- return()
- endif()
-
-- if (NOT CMAKE_CXX_COMPILER_ID STREQUAL ${IMHEX_REQUIRED_COMPILER} OR CMAKE_CXX_COMPILER_VERSION VERSION_LESS ${IMHEX_MIN_COMPILER_VERSION})
-- message(FATAL_ERROR "ImHex requires GCC ${IMHEX_MIN_COMPILER_VERSION} or newer. Please use the latest GCC version.")
-+ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS ${IMHEX_MIN_GCC_VERSION})
-+ message(FATAL_ERROR "ImHex requires GCC ${IMHEX_MIN_GCC_VERSION} or newer. Please use the latest GCC version.")
- endif()
- endfunction()
-
-@@ -369,10 +368,14 @@ function(downloadImHexPatternsFiles dest)
- endfunction()
-
- macro(setupCompilerWarnings target)
-- set(IMHEX_COMMON_FLAGS "-Wall -Wextra -Werror")
-- set(IMHEX_C_FLAGS "${IMHEX_COMMON_FLAGS} -Wno-restrict -Wno-stringop-overread")
-+ set(IMHEX_COMMON_FLAGS "")
-+ set(IMHEX_C_FLAGS "${IMHEX_COMMON_FLAGS}")
-+
-+ if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
-+ set(IMHEX_C_FLAGS "${IMHEX_C_FLAGS} -Wno-restrict -Wno-stringop-overread")
-+ endif()
-
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${IMHEX_C_FLAGS}")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${IMHEX_C_FLAGS}")
- set(CMAKE_OBJC_FLAGS "${CMAKE_OBJC_FLAGS} ${IMHEX_COMMON_FLAGS}")
--endmacro()
-\ No newline at end of file
-+endmacro()
---
-2.37.1
-
diff --git a/0002-fix-Deduplicate-resources-directories.patch b/0002-fix-Deduplicate-resources-directories.patch
index 273cf8c04a56..e57bb3fd01c6 100644
--- a/0002-fix-Deduplicate-resources-directories.patch
+++ b/0002-fix-Deduplicate-resources-directories.patch
@@ -1,4 +1,4 @@
-From 13a35764a80c550824157149bc433d474ef8f901 Mon Sep 17 00:00:00 2001
+From 8477deede059dfc3a3b413624914f9ed00840e9d Mon Sep 17 00:00:00 2001
From: KokaKiwi <kokakiwi+git@kokakiwi.net>
Date: Sat, 11 Jun 2022 23:08:31 +0200
Subject: [PATCH 2/2] fix: Deduplicate resources directories
@@ -32,7 +32,7 @@ index 025b5f76..f6baaaa6 100644
std::string combineStrings(const std::vector<std::string> &strings, const std::string &delimiter = "");
diff --git a/lib/libimhex/source/helpers/fs.cpp b/lib/libimhex/source/helpers/fs.cpp
-index 55dc08b2..8e52cfce 100644
+index dc58ced3..5c346ec8 100644
--- a/lib/libimhex/source/helpers/fs.cpp
+++ b/lib/libimhex/source/helpers/fs.cpp
@@ -1,4 +1,5 @@
@@ -41,7 +41,7 @@ index 55dc08b2..8e52cfce 100644
#include <hex/api/content_registry.hpp>
#include <hex/helpers/fs_macos.hpp>
-@@ -159,6 +160,8 @@ namespace hex::fs {
+@@ -156,6 +157,8 @@ namespace hex::fs {
auto additionalDirs = ImHexApi::System::getAdditionalFolderPaths();
std::copy(additionalDirs.begin(), additionalDirs.end(), std::back_inserter(paths));
@@ -51,8 +51,8 @@ index 55dc08b2..8e52cfce 100644
}
@@ -175,6 +178,8 @@ namespace hex::fs {
- auto dataDirs = xdg::DataDirs();
- std::copy(dataDirs.begin(), dataDirs.end(), std::back_inserter(paths));
+ for (auto &path : paths)
+ path = path / "imhex";
+ hex::deduplicateVector(paths);
+
@@ -60,5 +60,5 @@ index 55dc08b2..8e52cfce 100644
#endif
}
--
-2.37.1
+2.37.2
diff --git a/PKGBUILD b/PKGBUILD
index 7f32e9ebbff8..7f847fc3c912 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
-pkgver=1.20.0
-pkgrel=2
+pkgver=1.21.0
+pkgrel=1
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://imhex.werwolv.net'
license=('GPL2')
@@ -22,7 +22,7 @@ source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
"libromfs::git+https://github.com/WerWolv/libromfs"
"capstone::git+https://github.com/capstone-engine/capstone#branch=next"
"pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v$pkgver"
- 0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch
+ 0001-makepkg-Fix-compiler-flags.patch
0002-fix-Deduplicate-resources-directories.patch)
cksums=('SKIP'
'SKIP'
@@ -30,24 +30,24 @@ cksums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '1164761330'
- '1600868006')
+ '545604144'
+ '3160577462')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'ecc146f00787774d72581fa684064eb42598c0f0cc721b4d72c1d02324377107'
- 'aaeb91e6de14b4f8d59834a44a9209bc2829553b7b11ede72112098a533384ae')
+ 'ac4bf097441311abb860c423521eba2fa152194d9294b10ef403bbd8eb6105a1'
+ '091a4824ceb3f1f5da5efc1ee6ac025b1ab9b56d07bd75bdb52fae71f7dec046')
b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'c1901108a6f558dc0e3a2695778f1dd633762c726962284de55eb1fd451ab325b4605b801d0dd3471c354e506a3e805c8147908b108a63982d5424baa71a38ce'
- '51be06849a16eec5180a7523c2c78ac39238cb85d7d0d048691c45d8e38236f96c2b07c735970d5e282ff401a2146fad0764c2d9fa1fcab529865615118d69b1')
+ 'e52df3fc4629151b2156f4d75b13b1d7ac7bff07cebb151da391a3982c71608f7797a03cff5c560263ac46f32843f08b23437c31f9ef729e2e4ccc2bdb826900'
+ '456edc844d9934be7fc7918ca15d82242df54563e400b6d58a20dd739793495834a9ac147517a2c88139926bef97f195849cd5a0b4b303cf452d4ef4317cb1af')
options=(!lto)
prepare() {
@@ -63,12 +63,12 @@ prepare() {
git submodule update
git apply \
- "$srcdir/0001-makepkg-Fix-compiler-verification-and-compiler-flags.patch" \
+ "$srcdir/0001-makepkg-Fix-compiler-flags.patch" \
"$srcdir/0002-fix-Deduplicate-resources-directories.patch"
}
build() {
- export CXXFLAGS="$CXXFLAGS -Wno-inconsistent-missing-override"
+ export CXXFLAGS="$CXXFLAGS -Wno-inconsistent-missing-override -Wno-stringop-overflow"
cmake -B build -S "$pkgname" \
-Wno-dev \