summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2022-07-05 01:57:34 +0200
committerKokaKiwi2022-07-05 01:57:34 +0200
commitd10a221f678a8669d7e2eb578eba6dd63ae69b62 (patch)
tree0ea8bc52047c59c2234cbff9b61868ff0731d8bb
parentd69707604987bed930744a0690cf76d2c648debb (diff)
downloadaur-d10a221f678a8669d7e2eb578eba6dd63ae69b62.tar.gz
Fix clang build (temp fix)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0878f6a612b..98a5a9aee684 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imhex
pkgdesc = A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM
pkgver = 1.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/WerWolv/ImHex
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index ae5cd11a9921..2181c38c6efe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=ImHex
pkgname=${_pkgname,,}
pkgver=1.19.0
-pkgrel=1
+pkgrel=2
pkgdesc='A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM'
url='https://github.com/WerWolv/ImHex'
license=('GPL2')
@@ -77,10 +77,14 @@ prepare() {
}
build() {
+ export CXXFLAGS="$CXXFLAGS -Wno-inconsistent-missing-override"
+
cmake -B build -S "$pkgname" \
-Wno-dev \
-D CMAKE_BUILD_TYPE=RelWithDebInfo \
-D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_C_COMPILER="$CC" -D CMAKE_CXX_COMPILER="$CXX" \
+ -D CMAKE_C_FLAGS="$CFLAGS" -D CMAKE_CXX_FLAGS="$CXXFLAGS" \
-D CMAKE_SKIP_RPATH=ON \
-D USE_SYSTEM_LLVM=ON \
-D USE_SYSTEM_YARA=ON \