summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2023-09-22 12:39:35 +0200
committerKokaKiwi2023-09-22 12:39:35 +0200
commitd6c33990bb0f87cfbc0ffd885c9446d082395969 (patch)
tree909f7edca506c8a45ed3d31e5ce70a9160b9ebb9
parent4399b98041e66073ab24bc1306d5dec74fd9be8c (diff)
downloadaur-d6c33990bb0f87cfbc0ffd885c9446d082395969.tar.gz
upgpkg: imhex 1.30.1-2
Fix build
-rw-r--r--.SRCINFO7
-rw-r--r--0001-makepkg-Fix-compiler-check.patch4
-rw-r--r--0002-fix-CI-being-broken-on-Arch-Linux.patch25
-rw-r--r--PKGBUILD10
4 files changed, 39 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d06e579737eb..4b0b4920bad7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,6 +34,7 @@ pkgbase = imhex
source = pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v1.30.1
source = imhex-patterns::git+https://github.com/WerWolv/ImHex-Patterns#tag=ImHex-v1.30.1
source = 0001-makepkg-Fix-compiler-check.patch
+ source = 0002-fix-CI-being-broken-on-Arch-Linux.patch
source = pl-0001-Use-C-23-standard.patch
source = pl-0002-makepkg-Remove-extraneous-compiler-flags.patch
sha256sums = SKIP
@@ -44,7 +45,8 @@ pkgbase = imhex
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 8e422b77cbd5358205405268668b348700e30eb4efae175e73b11b0d5571d3a5
+ sha256sums = 90b83d03d5ef38f44aec8335857e47c786450c652766e720d5d98ad3cebc409d
+ sha256sums = 9264c83e389dfa0d0310a4081a51fff96788309a406fad5d4ccb19ea36bdd758
sha256sums = 9450b68e9fa61ade7ca64251bd1c1e3ed281ccae3795d933f7212ea7927770ab
sha256sums = e55aecea0c46a0d7627476c43767de827e253399dee588ddfb4cb70853bceb8a
b2sums = SKIP
@@ -55,7 +57,8 @@ pkgbase = imhex
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
- b2sums = afd4c41f6065b72f6cb6e6a0677f0ff56a165202752a9357e7585eba710816fcdeb4fe04897bcb9f8c40e29de8df92abf1da0873b9d5440c6551ab2683b1ac42
+ b2sums = 3face06d85b0b071952be1a31ad674fdf55027b05bb07609854bd4480d75958707fcf29ca9fa8b4bec307d5bf8ec4c5122df248cca406b4119a7a0ee5ef6ff56
+ b2sums = bcdc990dcea05b04a2fc57928b6146e5c7993f56d268b19b3927771e1e2ebd6bd8683c860085c0811bd235c27209a19ec0394b65edefa12e2c20e9e3674f7c8b
b2sums = 61be56bfa2fc9dc5e4a8e5af1c82852326c662fffcc98c094aaa68945cb00c21f856e0c3bba6b815fe584bc65bad564ddda632486021943ab939e829cf9ad892
b2sums = f9067bd94f1c7ed4551fe31408eebc151884a20f292a48bf23f2c4fc963b3af076c464f8fcbfb97cd3c713b4088a66e5cef8b41c2ce94e39af04e5dc5c1f377d
diff --git a/0001-makepkg-Fix-compiler-check.patch b/0001-makepkg-Fix-compiler-check.patch
index b92824cc0ebc..b10e859e3aa7 100644
--- a/0001-makepkg-Fix-compiler-check.patch
+++ b/0001-makepkg-Fix-compiler-check.patch
@@ -1,7 +1,7 @@
From f4725cc59a7bea460ccb6c55c918da048c16b1cb Mon Sep 17 00:00:00 2001
From: KokaKiwi <kokakiwi+git@kokakiwi.net>
Date: Mon, 14 Nov 2022 11:58:59 +0100
-Subject: [PATCH] makepkg: Fix compiler check
+Subject: [PATCH 1/2] makepkg: Fix compiler check
---
cmake/build_helpers.cmake | 21 ++++++++++-----------
@@ -81,5 +81,5 @@ index 624e4012..8087e749 100644
\ No newline at end of file
+endfunction()
--
-2.41.0
+2.42.0
diff --git a/0002-fix-CI-being-broken-on-Arch-Linux.patch b/0002-fix-CI-being-broken-on-Arch-Linux.patch
new file mode 100644
index 000000000000..e82fd4dcafad
--- /dev/null
+++ b/0002-fix-CI-being-broken-on-Arch-Linux.patch
@@ -0,0 +1,25 @@
+From 43b2c6d8be45d61ba9a541b01ef37ffa8f0b1290 Mon Sep 17 00:00:00 2001
+From: WerWolv <werwolv98@gmail.com>
+Date: Wed, 16 Aug 2023 23:07:16 +0200
+Subject: [PATCH 2/2] fix: CI being broken on Arch Linux
+
+---
+ lib/libimhex/include/hex/api/localization.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/libimhex/include/hex/api/localization.hpp b/lib/libimhex/include/hex/api/localization.hpp
+index 723a9a42..11e068b6 100644
+--- a/lib/libimhex/include/hex/api/localization.hpp
++++ b/lib/libimhex/include/hex/api/localization.hpp
+@@ -64,6 +64,6 @@ template<>
+ struct fmt::formatter<hex::LangEntry> : fmt::formatter<std::string_view> {
+ template<typename FormatContext>
+ auto format(const hex::LangEntry &entry, FormatContext &ctx) {
+- return fmt::formatter<std::string_view>::format(entry, ctx);
++ return fmt::formatter<std::string_view>::format(entry.get(), ctx);
+ }
+ };
+\ No newline at end of file
+--
+2.42.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 495a9497722d..79873e2d9178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,7 @@ source=("$pkgname::git+https://github.com/WerWolv/ImHex.git#tag=v$pkgver"
"pattern_language::git+https://github.com/WerWolv/PatternLanguage#tag=ImHex-v$pkgver"
"imhex-patterns::git+https://github.com/WerWolv/ImHex-Patterns#tag=ImHex-v$pkgver"
0001-makepkg-Fix-compiler-check.patch
+ 0002-fix-CI-being-broken-on-Arch-Linux.patch
pl-0001-Use-C-23-standard.patch
pl-0002-makepkg-Remove-extraneous-compiler-flags.patch)
sha256sums=('SKIP'
@@ -34,7 +35,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '8e422b77cbd5358205405268668b348700e30eb4efae175e73b11b0d5571d3a5'
+ '90b83d03d5ef38f44aec8335857e47c786450c652766e720d5d98ad3cebc409d'
+ '9264c83e389dfa0d0310a4081a51fff96788309a406fad5d4ccb19ea36bdd758'
'9450b68e9fa61ade7ca64251bd1c1e3ed281ccae3795d933f7212ea7927770ab'
'e55aecea0c46a0d7627476c43767de827e253399dee588ddfb4cb70853bceb8a')
b2sums=('SKIP'
@@ -45,7 +47,8 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'afd4c41f6065b72f6cb6e6a0677f0ff56a165202752a9357e7585eba710816fcdeb4fe04897bcb9f8c40e29de8df92abf1da0873b9d5440c6551ab2683b1ac42'
+ '3face06d85b0b071952be1a31ad674fdf55027b05bb07609854bd4480d75958707fcf29ca9fa8b4bec307d5bf8ec4c5122df248cca406b4119a7a0ee5ef6ff56'
+ 'bcdc990dcea05b04a2fc57928b6146e5c7993f56d268b19b3927771e1e2ebd6bd8683c860085c0811bd235c27209a19ec0394b65edefa12e2c20e9e3674f7c8b'
'61be56bfa2fc9dc5e4a8e5af1c82852326c662fffcc98c094aaa68945cb00c21f856e0c3bba6b815fe584bc65bad564ddda632486021943ab939e829cf9ad892'
'f9067bd94f1c7ed4551fe31408eebc151884a20f292a48bf23f2c4fc963b3af076c464f8fcbfb97cd3c713b4088a66e5cef8b41c2ce94e39af04e5dc5c1f377d')
options=(!lto !strip)
@@ -70,7 +73,8 @@ prepare() {
submodule update
git apply \
- "$srcdir/0001-makepkg-Fix-compiler-check.patch"
+ "$srcdir/0001-makepkg-Fix-compiler-check.patch" \
+ "$srcdir/0002-fix-CI-being-broken-on-Arch-Linux.patch"
git -C lib/external/pattern_language apply \
"$srcdir/pl-0001-Use-C-23-standard.patch" \