summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyojo2022-02-11 01:35:54 -0500
committerKyojo2022-02-11 01:35:54 -0500
commit0487445016907573a2d55c32637fae086c235067 (patch)
treecd5ebd7183b66d48207242b9f1a2e6142f0ea2b0
parentd0c09b59a9b658b9839236ef6e0020d32a669e32 (diff)
downloadaur-0487445016907573a2d55c32637fae086c235067.tar.gz
Fixed missing plugins
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbb5a93fb7ec..07a3d8593590 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@ pkgdesc="A Hex Editor for Reverse Engineers, Programmers and people that value t
arch=('x86_64')
url="https://github.com/WerWolv/ImHex"
license=('GPL2')
-depends=('glfw' 'glm' 'capstone' 'llvm-libs' 'llvm' 'nlohmann-json' 'python')
-makedepends=('git' 'cmake')
+depends=('glfw' 'glm' 'capstone' 'llvm' 'nlohmann-json' 'python' 'file' 'gtk3' 'mbedtls' 'libssh2')
+makedepends=('git' 'cmake' 'gcc' 'lld')
optdepends=()
provides=('imhex')
conflicts=('imhex')
@@ -25,11 +25,12 @@ build() {
cd "$pkgname"
git submodule update --init --recursive
cmake -B build -DCMAKE_INSTALL_PREFIX=/usr
- make -C build
+ make -j -C build
}
package() {
cd "$pkgname"
-
+ install -DTm755 build/lib/libimhex/libimhex.so "${pkgdir}/usr/lib/libimhex.so"
+ install -Dm755 build/plugins/builtin/builtin.hexplug "${pkgdir}/usr/bin/plugins/builtin.hexplug"
install -DTm755 build/imhex "${pkgdir}/usr/bin/imhex"
}