summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaruman92020-12-04 11:50:20 +0300
committersaruman92020-12-04 11:53:50 +0300
commit7763eeace2523c546a68d6e4e0f809c5dfe83e85 (patch)
tree9d890f716333e154f07353ac84cc4c6a14eba095
downloadaur-7763eeace2523c546a68d6e4e0f809c5dfe83e85.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e9052ba5f5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = imhex-git
+ pkgdesc = A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM
+ pkgver = 1.4.0.r23.gd7af693
+ pkgrel = 1
+ url = https://github.com/WerWolv/ImHex
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = glfw
+ depends = glm
+ depends = capstone
+ depends = llvm-libs
+ depends = llvm
+ depends = nlohmann-json
+ depends = python
+ provides = imhex
+ conflicts = imhex
+ source = imhex-git::git+https://github.com/WerWolv/ImHex.git
+ sha256sums = SKIP
+
+pkgname = imhex-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abcffe85ecd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alex Sarum <rum.274.4 at gmail dot com>
+
+pkgname=imhex-git
+pkgver=1.4.0.r23.gd7af693
+pkgrel=1
+pkgdesc="A Hex Editor for Reverse Engineers, Programmers and people that value their eye sight when working at 3 AM"
+arch=('x86_64')
+url="https://github.com/WerWolv/ImHex"
+license=('GPL2')
+depends=('glfw' 'glm' 'capstone' 'llvm-libs' 'llvm' 'nlohmann-json' 'python')
+makedepends=('git' 'cmake')
+optdepends=()
+provides=('imhex')
+conflicts=('imhex')
+source=("$pkgname::git+https://github.com/WerWolv/ImHex.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+package() {
+ cd "$pkgname"
+
+ install -DTm755 build/ImHex "${pkgdir}/usr/bin/imhex"
+}