summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2018-12-19 06:34:10 -0500
committerDaniel Moch2018-12-19 06:34:10 -0500
commitf0114e7287422a071e0463fb36a9a50e038510fd (patch)
treeae2d5599b4c48d724a2abc9d57f8fca32dd6377f
parent7cbb6f8b9264adeb1ddc05068866a76a1a64af66 (diff)
downloadaur-f0114e7287422a071e0463fb36a9a50e038510fd.tar.gz
upgpkg: imlib2-heic 0.1.0-2
Fix license
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--LICENSE29
-rw-r--r--PKGBUILD11
4 files changed, 40 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a7f1da1bb0f..23462effcc03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = imlib2-heic
pkgdesc = HEIC/HEIF decoder for imlib2
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vi/imlib2-heic
arch = x86_64
- license = LGPL
+ license = BSD
makedepends = git
depends = imlib2
depends = libheif
source = git+https://github.com/vi/imlib2-heic.git#commit=d500fad6cc2411e41daaf305b77428bf2aa6c681?signed
+ source = LICENSE
validpgpkeys = 331079CCE5FF6E6C6F2B3019C097221D6E03DF68
sha256sums = SKIP
+ sha256sums = 003ec66759cd96918994a2b65f19352c3caf75def596a6fa047d5ed78b12b7c8
pkgname = imlib2-heic
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..ca2305ee28db 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
pkg/
src/
*.tar.*
+imlib2-heic/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9a1e6864a313
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,29 @@
+Copyright (c) 2011 David Hauweele <david@hauweele.net>
+All rights reserved.
+
+Modified by Vitaly "_Vi" Shukela to use heic instead of webp.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index eb8776af68f7..765f73ea0ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,17 @@
_commit=d500fad6cc2411e41daaf305b77428bf2aa6c681
pkgname=imlib2-heic
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="HEIC/HEIF decoder for imlib2"
arch=('x86_64')
url="https://github.com/vi/${pkgname}"
-# for license, see https://github.com/vi/imlib2-heic/issues/1
-license=('LGPL')
+license=('BSD')
depends=(imlib2 libheif)
makedepends=(git)
-source=("git+${url}.git#commit=${_commit}?signed")
+source=("git+${url}.git#commit=${_commit}?signed" "LICENSE")
validpgpkeys=('331079CCE5FF6E6C6F2B3019C097221D6E03DF68') # Vitaly Shukela
-sha256sums=('SKIP')
+sha256sums=('SKIP'
+ '003ec66759cd96918994a2b65f19352c3caf75def596a6fa047d5ed78b12b7c8')
build()
{
@@ -24,6 +24,7 @@ build()
package()
{
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd ${pkgname}
make install DESTDIR=${pkgdir}
}