summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMole Shang2023-11-17 10:18:50 +0800
committerMole Shang2023-11-17 10:18:50 +0800
commit4a0c5820c88d90d1cd011dab3e36bc66904bef84 (patch)
tree03ac5e8014e9988df3485d1dff05ce8db48aeb9e
parent5ad9c84ecac7cbe5789ca40b25058fb58189882e (diff)
downloadaur-4a0c5820c88d90d1cd011dab3e36bc66904bef84.tar.gz
1.5.0-1
- Drop upstreamed patch (tsl0922/ImPlay@afebd61)
-rw-r--r--.SRCINFO8
-rw-r--r--0001-disable-unneeded-imgui-demo-window.patch40
-rw-r--r--PKGBUILD20
3 files changed, 11 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e21b53c7345a..8901c63d230e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = implay
pkgdesc = Desktop media player built on top of mpv and imgui
- pkgver = 1.4.0
- pkgrel = 7
+ pkgver = 1.5.0
+ pkgrel = 1
url = https://github.com/tsl0922/ImPlay
arch = x86_64
license = GPL3
@@ -12,9 +12,7 @@ pkgbase = implay
depends = mpv
depends = glfw
depends = xdg-desktop-portal
- source = implay::git+https://github.com/tsl0922/ImPlay.git#commit=9d6d1f58754032e3ea5a313ff8534b8439dc13f7
- source = 0001-disable-unneeded-imgui-demo-window.patch
+ source = implay::git+https://github.com/tsl0922/ImPlay.git#tag=5568222c25e6389b6c8948031c5893e5743b70c5
sha256sums = SKIP
- sha256sums = 7d8e03542e38cfbec2e3bf96e21e8d957c0b4c8edd92165a36d98b539742b49e
pkgname = implay
diff --git a/0001-disable-unneeded-imgui-demo-window.patch b/0001-disable-unneeded-imgui-demo-window.patch
deleted file mode 100644
index df0bf1178ae3..000000000000
--- a/0001-disable-unneeded-imgui-demo-window.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 8100b5940ca5bad8438bc0b7c9ea1d2a9b171c0a Mon Sep 17 00:00:00 2001
-From: Mole Shang <135e2@135e2.dev>
-Date: Sat, 11 Nov 2023 00:26:56 +0800
-Subject: [PATCH] disable unneeded imgui demo window
-
-This commit disables the demo window in ImPlay to eliminate a warning
-produced by makepkg on Arch Linux:
-
-==> WARNING: Package contains reference to $srcdir
-usr/bin/ImPlay
-
-After investigating for quite a while, a reference to
-third_party/imgui/imgui_debug.cpp was found to be the cause:
-
-strings pkg/implay/usr/bin/ImPlay | grep -F src
-src/implay/third_party/imgui/source/imgui_demo.cpp
-
-To address the issue, this commit uses the IMGUI_DISABLE_DEMO_WINDOWS
-macro to suppress demo calls, which are mostly not needed by end users
-like us on arch.
----
- third_party/imgui/include/imconfig.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/third_party/imgui/include/imconfig.h b/third_party/imgui/include/imconfig.h
-index 864c1b3..9face23 100644
---- a/third_party/imgui/include/imconfig.h
-+++ b/third_party/imgui/include/imconfig.h
-@@ -33,7 +33,7 @@
- //---- Disable all of Dear ImGui or don't implement standard windows/tools.
- // It is very strongly recommended to NOT disable the demo windows and debug tool during development. They are extremely useful in day to day work. Please read comments in imgui_demo.cpp.
- //#define IMGUI_DISABLE // Disable everything: all headers and source files will be empty.
--//#define IMGUI_DISABLE_DEMO_WINDOWS // Disable demo windows: ShowDemoWindow()/ShowStyleEditor() will be empty.
-+#define IMGUI_DISABLE_DEMO_WINDOWS // Disable demo windows: ShowDemoWindow()/ShowStyleEditor() will be empty.
- //#define IMGUI_DISABLE_DEBUG_TOOLS // Disable metrics/debugger and other debug tools: ShowMetricsWindow(), ShowDebugLogWindow() and ShowIDStackToolWindow() will be empty.
-
- //---- Don't implement some functions to reduce linkage requirements.
---
-2.42.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 290cfb157258..1292b8d19a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mole Shang <135e2@135e2.dev>
pkgname=implay
-pkgver=1.4.0
-pkgrel=7
+pkgver=1.5.0
+pkgrel=1
pkgdesc="Desktop media player built on top of mpv and imgui"
arch=('x86_64')
url="https://github.com/tsl0922/ImPlay"
@@ -18,17 +18,13 @@ makedepends=(
'freetype2'
)
optdepends=()
-source=(
- 'implay::git+https://github.com/tsl0922/ImPlay.git#commit=9d6d1f58754032e3ea5a313ff8534b8439dc13f7'
- '0001-disable-unneeded-imgui-demo-window.patch'
-)
-sha256sums=(
- 'SKIP'
- '7d8e03542e38cfbec2e3bf96e21e8d957c0b4c8edd92165a36d98b539742b49e'
-)
+_tag=5568222c25e6389b6c8948031c5893e5743b70c5 # git rev-parse "${pkgver}"
+source=("implay::git+https://github.com/tsl0922/ImPlay.git#tag=${_tag}")
+sha256sums=('SKIP')
-prepare() {
- patch -d "${pkgname}" -Np1 -i "${srcdir}/0001-disable-unneeded-imgui-demo-window.patch"
+pkgver() {
+ cd ${pkgname}
+ git describe --tags
}
build() {