summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMole Shang2023-02-25 23:51:54 +0800
committerMole Shang2023-02-25 23:53:04 +0800
commit7de6186f6df1e9db82002dcdace33f7ec4afd865 (patch)
tree6e6ba940658f483398c08ab1811016f34945be2a
parent5a0f99b1a428f01b04367ae7a9ccf0ac48a2a034 (diff)
downloadaur-7de6186f6df1e9db82002dcdace33f7ec4afd865.tar.gz
1.3.3-3
- Move `glfw` to depends - Add a patch to solve `makepkg` warning
-rw-r--r--.SRCINFO6
-rw-r--r--0001-disable-unneeded-imgui-demo-window.patch37
-rw-r--r--PKGBUILD22
3 files changed, 58 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 469d98530cef..d13c8c137ef3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = implay
pkgdesc = Desktop media player built on top of mpv and imgui
pkgver = 1.3.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/tsl0922/ImPlay
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = gtk3
makedepends = freetype2
- makedepends = glfw
depends = mpv
+ depends = glfw
source = implay::git+https://github.com/tsl0922/ImPlay.git?tag=${pkgver}
+ source = 0001-disable-unneeded-imgui-demo-window.patch
sha256sums = SKIP
+ sha256sums = 3fc9762c0b634ed72df8197bd4d618a4bc3a8f85b94d3155cb42f870e1d00616
pkgname = implay
diff --git a/0001-disable-unneeded-imgui-demo-window.patch b/0001-disable-unneeded-imgui-demo-window.patch
new file mode 100644
index 000000000000..c66bb3aa6852
--- /dev/null
+++ b/0001-disable-unneeded-imgui-demo-window.patch
@@ -0,0 +1,37 @@
+From 92789d8a0848af83cec0fc286ea94cb0c2446dd5 Mon Sep 17 00:00:00 2001
+From: Mole Shang <135e2@135e2.dev>
+Date: Sat, 25 Feb 2023 23:25:10 +0800
+Subject: [PATCH] disable unneeded imgui demo window
+
+This commit disables the demo window in ImPlay to eliminate a warning produced by makepkg on Arch Linux:
+
+==> WARNING: Package contains reference to $srcdir
+usr/bin/ImPlay
+
+After investigating for quite a while, a reference to third_party/imgui/imgui_debug.cpp was found to be the cause:
+
+strings pkg/implay/usr/bin/ImPlay | grep -F src
+src/implay/third_party/imgui/source/imgui_demo.cpp
+
+To address the issue, this commit uses the IMGUI_DISABLE_DEMO_WINDOWS
+macro to suppress demo calls, which are mostly not needed by end users like us on arch.
+---
+ third_party/imgui/include/imconfig.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/third_party/imgui/include/imconfig.h b/third_party/imgui/include/imconfig.h
+index 11ce672..b769eda 100644
+--- a/third_party/imgui/include/imconfig.h
++++ b/third_party/imgui/include/imconfig.h
+@@ -33,7 +33,7 @@
+ //---- Disable all of Dear ImGui or don't implement standard windows/tools.
+ // It is very strongly recommended to NOT disable the demo windows and debug tool during development. They are extremely useful in day to day work. Please read comments in imgui_demo.cpp.
+ //#define IMGUI_DISABLE // Disable everything: all headers and source files will be empty.
+-//#define IMGUI_DISABLE_DEMO_WINDOWS // Disable demo windows: ShowDemoWindow()/ShowStyleEditor() will be empty.
++#define IMGUI_DISABLE_DEMO_WINDOWS // Disable demo windows: ShowDemoWindow()/ShowStyleEditor() will be empty.
+ //#define IMGUI_DISABLE_DEBUG_TOOLS // Disable metrics/debugger and other debug tools: ShowMetricsWindow(), ShowDebugLogWindow() and ShowStackToolWindow() will be empty (this was called IMGUI_DISABLE_METRICS_WINDOW before 1.88).
+
+ //---- Don't implement some functions to reduce linkage requirements.
+--
+2.39.2
+
diff --git a/PKGBUILD b/PKGBUILD
index c9079575a6e0..ad18d0f86933 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,33 @@
# Maintainer: Mole Shang <135e2@135e2.dev>
pkgname=implay
pkgver=1.3.3
-pkgrel=2
+pkgrel=3
pkgdesc="Desktop media player built on top of mpv and imgui"
arch=('x86_64')
url="https://github.com/tsl0922/ImPlay"
license=('GPL3')
-depends=('mpv')
+depends=(
+ 'mpv'
+ 'glfw'
+)
makedepends=(
'cmake'
'gtk3'
'freetype2'
- 'glfw'
)
optdepends=()
-source=('implay::git+https://github.com/tsl0922/ImPlay.git?tag=${pkgver}')
-sha256sums=('SKIP')
+source=(
+ 'implay::git+https://github.com/tsl0922/ImPlay.git?tag=${pkgver}'
+ '0001-disable-unneeded-imgui-demo-window.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '3fc9762c0b634ed72df8197bd4d618a4bc3a8f85b94d3155cb42f870e1d00616'
+)
+
+prepare() {
+ patch -d "${pkgname}" -Np1 -i "${srcdir}/0001-disable-unneeded-imgui-demo-window.patch"
+}
build() {
cd "${pkgname}"