summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 15:14:49 +0200
committerPiotr Rogoża2015-06-14 15:14:49 +0200
commit4cd0f8398f27e2bb5ced8e6c8d11eb2e0485ef73 (patch)
tree48107c54aeca3067727f45655079ea211a1cffce
downloadaur-4cd0f8398f27e2bb5ced8e6c8d11eb2e0485ef73.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
-rw-r--r--bboxx.148
-rw-r--r--fixtd.148
-rw-r--r--impose.148
-rw-r--r--psbl.148
6 files changed, 263 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..610662867e13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = impose+
+ pkgdesc = A set of utilities for manipulating DSC compliant postscript
+ pkgver = 0.2
+ pkgrel = 5
+ url = http://freshmeat.net/projects/impose/
+ arch = any
+ license = GPL
+ depends = perl
+ source = http://ftp.de.debian.org/debian/pool/main/i/impose+/impose+_0.2.orig.tar.gz
+ source = http://ftp.de.debian.org/debian/pool/main/i/impose+/impose+_0.2-12.diff.gz
+ source = impose.1
+ source = fixtd.1
+ source = psbl.1
+ source = bboxx.1
+ md5sums = 0aed00e591065cc808d6645950f18022
+ md5sums = dcbaf0e6b414580771a7a84ea1aa7219
+ md5sums = 5cb8e86f85c2f7b75131acba3535e717
+ md5sums = d25dad12ac9f3c0e39ac3904507a67e5
+ md5sums = 963edbaffa48059c1b53334391a95750
+ md5sums = cfc449ca27234b802c4ee51009dbe626
+
+pkgname = impose+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bda4b41d6825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+
+pkgname=impose+
+pkgver=0.2
+pkgrel=5
+pkgdesc='A set of utilities for manipulating DSC compliant postscript'
+arch=('any')
+url='http://freshmeat.net/projects/impose/'
+license=('GPL')
+depends=(perl)
+source=(
+http://ftp.de.debian.org/debian/pool/main/i/$pkgname/${pkgname}_${pkgver}.orig.tar.gz
+http://ftp.de.debian.org/debian/pool/main/i/$pkgname/${pkgname}_${pkgver}-12.diff.gz
+impose.1
+fixtd.1
+psbl.1
+bboxx.1
+)
+
+build() {
+
+ cd "$srcdir/$pkgname-$pkgver" || return 1
+ sed -i 's#/usr/local/bin/perl#/usr/bin/perl#' psbl fixtd || return 1
+
+ install -dm755 ${pkgdir}/usr/bin || return 1
+ for i in psbl impose fixtd bboxx; do
+ install -Dm755 $i ${pkgdir}/usr/bin/ || return 1
+ done
+
+ install -dm755 ${pkgdir}/usr/share/doc/impose+ || return 1
+ install -Dm644 html/* ${pkgdir}/usr/share/doc/impose+/ || return 1
+
+ install -dm755 ${pkgdir}/usr/share/impose+ || return 1
+
+ for i in AUTHORS README TODO; do
+ install -Dm644 $i ${pkgdir}/usr/share/impose+/ || return 1
+ done
+
+ install -dm755 ${pkgdir}/usr/share/man/man1 || return 1
+ install -Dm644 ../*.1 ${pkgdir}/usr/share/man/man1/ || return 1
+}
+md5sums=('0aed00e591065cc808d6645950f18022'
+ 'dcbaf0e6b414580771a7a84ea1aa7219'
+ '5cb8e86f85c2f7b75131acba3535e717'
+ 'd25dad12ac9f3c0e39ac3904507a67e5'
+ '963edbaffa48059c1b53334391a95750'
+ 'cfc449ca27234b802c4ee51009dbe626')
diff --git a/bboxx.1 b/bboxx.1
new file mode 100644
index 000000000000..e7dd4dc02931
--- /dev/null
+++ b/bboxx.1
@@ -0,0 +1,48 @@
+.\" Title: BBOXX
+.\" Author: Yaroslav Halchenko
+.\" Generator: DocBook XSL Stylesheets v1.73.2 <http://docbook.sf.net/>
+.\" Date: February 4, 2004
+.\" Manual:
+.\" Source:
+.\"
+.TH "BBOXX" "1" "February 4, 2004" "" ""
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+bboxx \- The program outputs the page number and the Bounding Box parameters for every page in the file filename, by postprocessing the output from the gs bbox device.
+.SH "SYNOPSIS"
+.HP 6
+\fBbboxx\fR [\fB\-help\fR] [\fB\-letter|\-a4\fR] [\fB\-res\ \fR\fB\fIres\fR\fR] [\fB\-insert\ \fR] [\fB\-bypbm\ \fR] [\fB\-pages\ \fR\fB\fIp\fR\fR\fB\ \fR] [\fB\-evenodd\ \fR]\fI postscript\&.file \fR
+.SH "DESCRIPTION"
+.PP
+This manual page documents briefly the
+\fBbboxx\fR\&. Run it with \'\-help\' to see description of options
+.PP
+This manual page was written for the
+Debian(TM)
+distribution because the original program does not have a manual page\&.
+.SH "SEE ALSO"
+.PP
+impose (1), fixtd (1), psbl (1)\&.
+.SH "AUTHOR"
+.PP
+This manual page was written by Yaroslav Halchenko
+<debian@onerussian\&.com>
+for the
+Debian(TM)
+system (but may be used by others)\&. Permission is granted to copy, distribute and/or modify this document under the terms of the
+GNU
+General Public License, Version 2 any later version published by the Free Software Foundation\&.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL\&.
+.SH "AUTHOR"
+.PP
+\fBYaroslav Halchenko\fR
+.sp -1n
+.IP "" 4
+Author.
+.SH "COPYRIGHT"
+Copyright \(co 2003 Yaroslav Halchenko
+.br
diff --git a/fixtd.1 b/fixtd.1
new file mode 100644
index 000000000000..f0dabfb17af4
--- /dev/null
+++ b/fixtd.1
@@ -0,0 +1,48 @@
+.\" Title: FIXTD
+.\" Author: Yaroslav Halchenko
+.\" Generator: DocBook XSL Stylesheets v1.73.2 <http://docbook.sf.net/>
+.\" Date: February 4, 2004
+.\" Manual:
+.\" Source:
+.\"
+.TH "FIXTD" "1" "February 4, 2004" "" ""
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+fixtd \- insert tumble and duplex directives in a PostScript file
+.SH "SYNOPSIS"
+.HP 6
+\fBfixtd\fR [\fB\-help\fR] [\fB\-simplex\fR] [\fB\-tumble\fR]\fI postscript\&.file \fR
+.SH "DESCRIPTION"
+.PP
+This manual page documents briefly the
+\fBfixtd\fR\&. Run it with \'\-help\' to see description of options
+.PP
+This manual page was written for the
+Debian(TM)
+distribution because the original program does not have a manual page\&.
+.SH "SEE ALSO"
+.PP
+impose (1), psbl (1), bboxx (1)\&.
+.SH "AUTHOR"
+.PP
+This manual page was written by Yaroslav Halchenko
+<debian@onerussian\&.com>
+for the
+Debian(TM)
+system (but may be used by others)\&. Permission is granted to copy, distribute and/or modify this document under the terms of the
+GNU
+General Public License, Version 2 any later version published by the Free Software Foundation\&.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL\&.
+.SH "AUTHOR"
+.PP
+\fBYaroslav Halchenko\fR
+.sp -1n
+.IP "" 4
+Author.
+.SH "COPYRIGHT"
+Copyright \(co 2003 Yaroslav Halchenko
+.br
diff --git a/impose.1 b/impose.1
new file mode 100644
index 000000000000..66198f7d09ea
--- /dev/null
+++ b/impose.1
@@ -0,0 +1,48 @@
+.\" Title: IMPOSE
+.\" Author: Yaroslav Halchenko
+.\" Generator: DocBook XSL Stylesheets v1.73.2 <http://docbook.sf.net/>
+.\" Date: February 4, 2004
+.\" Manual:
+.\" Source:
+.\"
+.TH "IMPOSE" "1" "February 4, 2004" "" ""
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+impose \- impose is used for two-up printing of DSC complient postscript. It makes an effort to remove white space from the printout by probing the original postscript for the bounding box of the printed area. This makes the output much more esthetic than does a simplistic layout of non-cropped original papers.
+.SH "SYNOPSIS"
+.HP 7
+\fBimpose\fR [\fB\-help\fR] [\fB\-letter\fR] [\fB\-height\ \fR\fB\fIh\fR\fR] [\fB\-width\ \fR\fB\fIw\fR\fR] [\fB\-scale\ \fR\fB\fIs\fR\fR\fB\ \fR] [\fB\-noscale\ \fR] [\fB\-pages\ \fR\fB\fIp\fR\fR\fB\ \fR] [\fB\-xm\ \fR\fB\fIx\fR\fR\fB\ \fR] [\fB\-xrm\ \fR\fB\fIx\fR\fR\fB\ \fR] [\fB\-xlm\ \fR\fB\fIx\fR\fR\fB\ \fR] [\fB\-ym\ \fR\fB\fIy\fR\fR\fB\ \fR] [\fB\-gutter\ \fR] [\fB\-noglue\ \fR] [\fB\-bbox\ \fR\fB\fIb1,b2,b3,b4\fR\fR\fB\ \fR] [\fB\-noevenodd\ \fR] [\fB\-evenbbox\ \fR\fB\fIb1,b2,b3,b4\fR\fR\fB\ \fR] [\fB\-oddbbox\ \fR\fB\fIb1,b2,b3,b4\fR\fR\fB\ \fR] [\fB\-lastbbox\ \fR] [\fB\-stdout\ \fR] [\fB\-rtl\ \fR]\fI postscript\&.file \fR
+.SH "DESCRIPTION"
+.PP
+This manual page documents briefly the
+\fBimpose\fR\&. Run it with \'\-help\' to see description of options
+.PP
+This manual page was written for the
+Debian(TM)
+distribution because the original program does not have a manual page\&.
+.SH "SEE ALSO"
+.PP
+bboxx (1), fixtd (1), psbl (1)\&.
+.SH "AUTHOR"
+.PP
+This manual page was written by Yaroslav Halchenko
+<debian@onerussian\&.com>
+for the
+Debian(TM)
+system (but may be used by others)\&. Permission is granted to copy, distribute and/or modify this document under the terms of the
+GNU
+General Public License, Version 2 any later version published by the Free Software Foundation\&.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL\&.
+.SH "AUTHOR"
+.PP
+\fBYaroslav Halchenko\fR
+.sp -1n
+.IP "" 4
+Author.
+.SH "COPYRIGHT"
+Copyright \(co 2003 Yaroslav Halchenko
+.br
diff --git a/psbl.1 b/psbl.1
new file mode 100644
index 000000000000..8685485a2f7d
--- /dev/null
+++ b/psbl.1
@@ -0,0 +1,48 @@
+.\" Title: PSBL
+.\" Author: Yaroslav Halchenko
+.\" Generator: DocBook XSL Stylesheets v1.73.2 <http://docbook.sf.net/>
+.\" Date: February 4, 2004
+.\" Manual:
+.\" Source:
+.\"
+.TH "PSBL" "1" "February 4, 2004" "" ""
+.\" disable hyphenation
+.nh
+.\" disable justification (adjust text to left margin only)
+.ad l
+.SH "NAME"
+psbl \- A program for automatic booklet formatting of postscript files
+.SH "SYNOPSIS"
+.HP 5
+\fBpsbl\fR [\fB\-help\fR] [\fB\-lastbbox\fR] [\fB\-impose_option\ \fR\fB\fIio\fR\fR] [\fB\-lpi\ \fR] [\fB\-max_pages\ \fR\fB\fImp\fR\fR\fB\ \fR] [\fB\-evenodd\ \fR]\fI postscript\&.file \fR
+.SH "DESCRIPTION"
+.PP
+This manual page documents briefly the
+\fBpsbl\fR\&. Run it with \'\-help\' to see description of options
+.PP
+This manual page was written for the
+Debian(TM)
+distribution because the original program does not have a manual page\&.
+.SH "SEE ALSO"
+.PP
+impose (1), fixtd (1), bboxx (1)\&.
+.SH "AUTHOR"
+.PP
+This manual page was written by Yaroslav Halchenko
+<debian@onerussian\&.com>
+for the
+Debian(TM)
+system (but may be used by others)\&. Permission is granted to copy, distribute and/or modify this document under the terms of the
+GNU
+General Public License, Version 2 any later version published by the Free Software Foundation\&.
+.PP
+On Debian systems, the complete text of the GNU General Public License can be found in /usr/share/common\-licenses/GPL\&.
+.SH "AUTHOR"
+.PP
+\fBYaroslav Halchenko\fR
+.sp -1n
+.IP "" 4
+Author.
+.SH "COPYRIGHT"
+Copyright \(co 2003 Yaroslav Halchenko
+.br