summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolden Lewis2020-10-13 18:49:21 -0700
committerHolden Lewis2020-10-13 18:49:21 -0700
commit9f86d1868731b832989c1baccbec0eedf9cf02ef (patch)
tree20c99619d89498ee469452c931402a46be706880
parent2705e68e5d6c3d1c2cc9c22e02776af52f7e93c0 (diff)
downloadaur-9f86d1868731b832989c1baccbec0eedf9cf02ef.tar.gz
Add git submodule as source
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD3
3 files changed, 6 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94e0183ee108..9698c27ef105 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,10 @@ pkgbase = impostor-server
conflicts = impostor-server
options = !strip
source = git+https://github.com/AeonLucid/Impostor.git#tag=v1.1.0
+ source = git+https://github.com/AeonLucid/Hazel-Networking.git
source = https://dot.net/v1/dotnet-install.sh
sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = 7cdf91eda30e18ae3042ea77ad2a43e66e5a020df1ae09ff0b73f327385a34b51da3cd52361ef2714c853d30fffc8dd077733858b07ec6f79a444b6d8dcf637c
pkgname = impostor-server
diff --git a/.gitignore b/.gitignore
index af2bb617d9d9..dfb4a1e6560a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,5 @@
# Impostor
/Impostor/
+/Hazel-Networking/
/dotnet-install.sh
diff --git a/PKGBUILD b/PKGBUILD
index 8456c8022fc0..c21ae1967059 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,10 @@ provides=('impostor-server')
conflicts=('impostor-server')
options=('!strip')
source=("git+https://github.com/AeonLucid/Impostor.git#tag=v${pkgver}"
+ "git+https://github.com/AeonLucid/Hazel-Networking.git"
"https://dot.net/v1/dotnet-install.sh")
sha512sums=('SKIP'
+ 'SKIP'
'7cdf91eda30e18ae3042ea77ad2a43e66e5a020df1ae09ff0b73f327385a34b51da3cd52361ef2714c853d30fffc8dd077733858b07ec6f79a444b6d8dcf637c')
prepare() {
@@ -23,6 +25,7 @@ prepare() {
cd "Impostor/"
git submodule init
+ git config submodule.submodules/Hazel-Networking.url ${srcdir}/Hazel-Networking
git submodule update
}