summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFritzOnFire2018-01-19 16:34:01 +0200
committerFritzOnFire2018-01-19 16:34:01 +0200
commit3e5c8d1c4abd87658b837001153e6dbc605400d8 (patch)
tree598eef4a130db3386b742191408d5761a928d8b1
downloadaur-imqs-mapnik-git.tar.gz
Initial commit of imqs forked mapnik package
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD61
-rw-r--r--mapnik.install11
3 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c2df5d5f517
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = imqs-mapnik-git
+ pkgdesc = Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (imqs-git version)
+ pkgver = 3.0.15
+ pkgrel = 1
+ url = http://mapnik.org/
+ install = mapnik.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = scons
+ makedepends = boost
+ makedepends = git
+ depends = boost-libs
+ depends = icu
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = freetype2
+ depends = libxml2
+ depends = python2
+ depends = proj
+ depends = cairo
+ depends = cairomm
+ depends = python-cairo
+ depends = postgresql-libs
+ depends = postgis
+ depends = gdal
+ depends = curl
+ depends = libltdl
+ depends = libwebp
+ optdepends = libxslt: Web Map Service
+ optdepends = python2-lxml: Web Map Service
+ optdepends = python2-pillow: Web Map Service
+ optdepends = python-nose: Web Map Service
+ optdepends = apache: Web Map Service
+ optdepends = mod_fastcgi: Web Map Service - or:
+ optdepends = mod_fcgid: Web Map Service - or:
+ optdepends = mod_wsgi2: Web Map Service
+ provides = mapnik=3.0.15
+ conflicts = mapnik
+ options = staticlibs
+ source = git://github.com:IMQS/mapnik.git#branch=imqs-master
+ md5sums = SKIP
+
+pkgname = imqs-mapnik-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07685bd08102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id$
+# Maintainer: Fritz Engelbrecht <fritz.engl+arch@gmail.com>
+
+pkgname=imqs-mapnik-git
+_pkgname=mapnik
+pkgver=3.0.15
+pkgrel=1
+pkgdesc="Free Toolkit for developing mapping applications. Above all Mapnik is about rendering beautiful maps (imqs-git version)"
+arch=('i686' 'x86_64')
+url="http://mapnik.org/"
+license=('LGPL')
+depends=('boost-libs' 'icu' 'libpng' 'libjpeg' 'libtiff' 'freetype2'
+ 'libxml2' 'python2' 'proj' 'cairo' 'cairomm' 'python-cairo'
+ 'postgresql-libs' 'postgis' 'gdal' 'curl' 'libltdl' 'libwebp')
+optdepends=('libxslt: Web Map Service'
+ 'python2-lxml: Web Map Service'
+ 'python2-pillow: Web Map Service'
+ 'python-nose: Web Map Service'
+ 'apache: Web Map Service'
+ 'mod_fastcgi: Web Map Service - or:'
+ 'mod_fcgid: Web Map Service - or:'
+ 'mod_wsgi2: Web Map Service')
+makedepends=('scons' 'boost' 'git')
+conflicts=('mapnik')
+provides=('mapnik=3.0.15')
+options=(staticlibs)
+install="mapnik.install"
+source=("git://github.com/IMQS/mapnik.git#branch=imqs-master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ echo "3.0.15"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ git checkout imqs-master
+
+ # This is not how this should be done, will remove when fix is apply'd to repo
+ git cherry-pick d3ec91b29b364681e393ff7910b883d7f22e2243
+
+ git submodule update --init deps/mapbox
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ scons configure \
+ PREFIX="/usr" \
+ INPUT_PLUGINS=all \
+ DESTDIR="$pkgdir"
+ scons $MAKEFLAGS
+}
+
+package(){
+ cd "$srcdir/$_pkgname"
+ make PYTHON=python2 DESTDIR="$pkgdir" install
+}
diff --git a/mapnik.install b/mapnik.install
new file mode 100644
index 000000000000..46f265d5b51f
--- /dev/null
+++ b/mapnik.install
@@ -0,0 +1,11 @@
+post_install() {
+ /sbin/ldconfig
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}