summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2020-03-08 12:42:58 +0900
committerQue Quotion2020-03-08 12:42:58 +0900
commit4ec1e3d99e765dd36662cce80bb98f184bdb5815 (patch)
tree57abbf08d3fe44fc42bd5b575a93e40b0dd97a2e
parent81e8cade910636ad00e71f58af24879227225033 (diff)
downloadaur-4ec1e3d99e765dd36662cce80bb98f184bdb5815.tar.gz
fix complication for binutils 2.34+
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--binutils-update.patch22
3 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2563906cb2a..e5c343584824 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imule
pkgdesc = Anonymous P2P file sharing software
pkgver = 2.3.3.3
- pkgrel = 4
+ pkgrel = 5
url = http://www.imule.i2p/
arch = i686
arch = x86_64
@@ -10,7 +10,9 @@ pkgbase = imule
depends = crypto++
optdepends = i2p: anonymous routing
source = http://echelon.i2p/imule/2.3.3.3/iMule-2.3.3.3-src.tbz
+ source = binutils-update.patch
md5sums = fa2a2347063db98eb77d44fd3d4fcc8a
+ md5sums = a5209c71835220675ca801badb3f3cbc
pkgname = imule
diff --git a/PKGBUILD b/PKGBUILD
index aebef1a51262..e833557f9061 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=imule
pkgver=2.3.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="Anonymous P2P file sharing software"
arch=("i686" "x86_64")
url="http://www.imule.i2p/"
@@ -13,15 +13,18 @@ depends=("wxgtk" "crypto++")
optdepends=("i2p: anonymous routing")
# Does this even work?
-source=("http://echelon.i2p/imule/2.3.3.3/iMule-${pkgver}-src.tbz")
+source=("http://echelon.i2p/imule/2.3.3.3/iMule-${pkgver}-src.tbz"
+ binutils-update.patch)
export http_proxy=127.0.0.1:4444
# Use a libmakepkg plugin for i2p
-#source=("i2p+http://echelon.i2p/imule/2.3.3.3/iMule-${pkgver}-src.tbz")
+#source=("i2p+http://echelon.i2p/imule/2.3.3.3/iMule-${pkgver}-src.tbz"
+# binutils-update.patch)
prepare() {
cd "${srcdir}/iMule-${pkgver}-src"
sed -i 's/pubkey.DEREncode(asink);/pubkey.AccessMaterial().Save(asink);/g' src/ClientCreditsList.cpp
+ patch -Np0 < ../binutils-update.patch
}
build() {
@@ -44,4 +47,5 @@ package() {
#It's hack. If U know best way to not instal this desktop file tell me.
rm ${pkgdir}/usr/share/applications/imulegui.desktop
}
-md5sums=('fa2a2347063db98eb77d44fd3d4fcc8a')
+md5sums=('fa2a2347063db98eb77d44fd3d4fcc8a'
+ 'a5209c71835220675ca801badb3f3cbc')
diff --git a/binutils-update.patch b/binutils-update.patch
new file mode 100644
index 000000000000..93defdc619dc
--- /dev/null
+++ b/binutils-update.patch
@@ -0,0 +1,22 @@
+--- src/libs/common/MuleDebug.cpp 2020-03-08 12:28:52.588068625 +0900
++++ src/libs/common/MuleDebug.cpp 2020-03-08 12:29:18.837068569 +0900
+@@ -264,7 +264,7 @@
+ return;
+ }
+
+- bfd_vma vma = bfd_get_section_vma(abfd, section);
++ bfd_vma vma = bfd_section_vma(section);
+
+ unsigned long address = (unsigned long)_address;
+ if (address < vma) {
+--- src/libs/common/MuleDebug.cpp 2020-03-08 12:32:13.913068190 +0900
++++ src/libs/common/MuleDebug.cpp 2020-03-08 12:33:43.956067995 +0900
+@@ -271,7 +271,7 @@
+ return;
+ }
+
+- bfd_size_type size = bfd_section_size(abfd, section);
++ bfd_size_type size = bfd_section_size(section);
+ if (address > (vma + size)) {
+ return;
+ }