summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordenisSal2016-03-08 16:58:23 +0100
committerdenisSal2016-03-08 16:58:23 +0100
commit487fc2bdc1ba04878bffe3f04d8d9d2192348c64 (patch)
tree0d03a11bbd3c493e8a020000c60726b84e77034a
parent7a396a5cb95cdb266fb21b4e0c37b329382b29d8 (diff)
downloadaur-487fc2bdc1ba04878bffe3f04d8d9d2192348c64.tar.gz
no reason for sed anymore
Also updated patch for new GNUmakefile
-rw-r--r--0001-PKGBUILD-compat.patch40
-rw-r--r--PKGBUILD5
2 files changed, 12 insertions, 33 deletions
diff --git a/0001-PKGBUILD-compat.patch b/0001-PKGBUILD-compat.patch
index cea28d59739c..d51370d6319c 100644
--- a/0001-PKGBUILD-compat.patch
+++ b/0001-PKGBUILD-compat.patch
@@ -1,23 +1,12 @@
-From b64fcf0e8557552aa5c193bb20a6a89975528027 Mon Sep 17 00:00:00 2001
-From: Robin Nehls <nehls@mi.fu-berlin.de>
-Date: Thu, 19 Nov 2015 16:18:42 +0100
-Subject: [PATCH] PKGBUILD compat
-
----
- GNUmakefile | 13 +++++++------
- 1 file changed, 7 insertions(+), 6 deletions(-)
-
-diff --git a/GNUmakefile b/GNUmakefile
-index 56647ba..beab352 100644
---- a/GNUmakefile
-+++ b/GNUmakefile
+--- a/GNUmakefile 2016-02-29 13:33:22.915518271 +0100
++++ b/GNUmakefile 2016-02-29 13:47:39.938826378 +0100
@@ -1,4 +1,5 @@
PREFIX = /usr/local
+REALPREFIX = /usr/local
LIBDIR = lib/imunes
IMUNESDIR = $(PREFIX)/$(LIBDIR)
CONFIGDIR = $(IMUNESDIR)/config
-@@ -11,6 +12,7 @@ NORMAL_ICONSDIR = $(ICONSDIR)/normal
+@@ -12,6 +13,7 @@
SMALL_ICONSDIR = $(ICONSDIR)/small
TINY_ICONSDIR = $(ICONSDIR)/tiny
BINDIR = $(PREFIX)/bin
@@ -25,15 +14,15 @@ index 56647ba..beab352 100644
IMUNESDATE = `date +"%Y%m%d"`
IMUNESVER = 1.0
TARBALL_DIR = imunes_$(IMUNESDATE)
-@@ -47,19 +49,19 @@ info:
+@@ -50,21 +52,21 @@
all: install
--install: uninstall
-+install:
+-install: uninstall netgraph
++install: netgraph
mkdir -p $(IMUNESDIR)
cp $(BASEFILES) $(IMUNESDIR)
- sh scripts/update_version.sh
+ ROOTDIR=$(PREFIX) sh scripts/update_version.sh
mkdir -p $(BINDIR)
sed -e "s,set LIBDIR \"\",set LIBDIR $(LIBDIR)," \
@@ -41,6 +30,8 @@ index 56647ba..beab352 100644
+ -e "s,set ROOTDIR \".\",set ROOTDIR $(REALPREFIX)," \
imunes.tcl > $(IMUNESDIR)/imunes.tcl
+ cp helpers.tcl $(IMUNESDIR)
+
sed -e "s,LIBDIR=\"\",LIBDIR=$(LIBDIR)," \
- -e "s,ROOTDIR=\".\",ROOTDIR=$(PREFIX)," \
- -e "s,BINDIR=\".\",BINDIR=$(BINDIR)," \
@@ -49,7 +40,7 @@ index 56647ba..beab352 100644
imunes > $(BINDIR)/imunes
chmod 755 $(BINDIR)/imunes
-@@ -80,7 +82,7 @@ endif
+@@ -85,7 +87,7 @@
for file in $(VROOT); do \
sed -e "s,LIBDIR=\"\",LIBDIR=$(LIBDIR)," \
@@ -58,14 +49,3 @@ index 56647ba..beab352 100644
$${file} > $(IMUNESDIR)/$${file}; \
chmod 755 $(IMUNESDIR)/$${file}; \
done ;
-@@ -149,7 +151,6 @@ endif
-
- tarball:
- rm -f ../$(TARBALL_DIR).tar.gz
--
- mkdir -p ../$(TARBALL_DIR)
- cp $(FILES) $(BINARIES) $(VROOT) Makefile imunes imunes.tcl ../$(TARBALL_DIR)
-
---
-2.6.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 588106e42510..a9cdc906ad1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Robin Nehls <aur@manol.is>
pkgname=imunes-git
-pkgver=v2.1.0
+pkgver=v2.1.0.84.g82b01f1
pkgrel=1
pkgdesc="Integrated Multiprotocol Network Emulator/Simulator"
arch=('i686' 'x86_64')
@@ -13,7 +13,7 @@ provides=('imunes')
source=('git+https://github.com/imunes/imunes.git'
'0001-PKGBUILD-compat.patch')
sha1sums=('SKIP'
- 'ba1dbc566f352e3faeed62bc3561f3f01265c777')
+ '4d68f7f685222a23bb7d54d5cff78aa2da628135')
_gitname=imunes
pkgver() {
@@ -23,7 +23,6 @@ pkgver() {
prepare() {
cd $_gitname
- sed -i "s,ROOTDIR=\"/usr/local\",ROOTDIR=\"${pkgdir}/usr\"," scripts/update_version.sh
patch -p1 -i $srcdir/0001-PKGBUILD-compat.patch
}