summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-11-09 19:48:24 +0100
committeranthraxx2015-11-09 19:48:24 +0100
commite9bf471b38d6e1d1cf01a4fdf77e393167534efe (patch)
treea3db5f04f6c5893369b29fbfb205c2b18c2ac3b5
downloadaur-e9bf471b38d6e1d1cf01a4fdf77e393167534efe.tar.gz
addpkg: imvirt-git 0.9.6.231.1db4a69-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..229e6bcb17eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = imvirt-git
+ pkgdesc = Detect the virtualization technology of a machine, it is run in
+ pkgver = 0.9.6.231.1db4a69
+ pkgrel = 1
+ url = http://micky.ibh.net/~liske/imvirt.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = perl
+ depends = dmidecode
+ depends = perl-module-find
+ depends = perl-file-slurp
+ depends = perl-data-dumper
+ provides = imvirt
+ conflicts = imvirt
+ options = !emptydirs
+ source = imvirt-git::git+https://github.com/DE-IBH/imvirt
+ sha512sums = SKIP
+
+pkgname = imvirt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd93739c92cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributors: henning mueller <henning@orgizm.net>
+
+pkgname=imvirt-git
+_pkgname=${pkgname/-git}
+pkgver=0.9.6.231.1db4a69
+pkgrel=1
+pkgdesc='Detect the virtualization technology of a machine, it is run in'
+url='http://micky.ibh.net/~liske/imvirt.html'
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('perl' 'dmidecode' 'perl-module-find' 'perl-file-slurp' 'perl-data-dumper')
+makedepends=('git')
+provides=('imvirt')
+conflicts=('imvirt')
+options=('!emptydirs')
+source=(${pkgname}::git+https://github.com/DE-IBH/${_pkgname})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ sed 's|/usr/sbin|/usr/bin|g' -i perl/lib/ImVirt/Utils/dmidecode/pipe.pm
+}
+
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/usr --libexecdir=/usr/lib/${_pkgname} --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: