summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli2020-08-02 04:22:21 +0200
committerDenis 'GNUtoo' Carikli2020-08-02 04:32:37 +0200
commite084db2c39137561ae1acba932cc6c9a138f1a63 (patch)
tree069df8c66b9d2f83d9bd10c044c1ee1a73948b19
parent117464c37485fae763c30fa1fb07aa649a8fb25e (diff)
downloadaur-e084db2c39137561ae1acba932cc6c9a138f1a63.tar.gz
Really fix config files location
While making the previous patch to fix the config files location, I added the sysconfdir=/etc flag both to make and make install and tested that it worked fine. I then tested without sysconfdir=/etc flag for make and the resulting binary also worked, so I removed it. However I was building with makepkg, so it kept the result of the previous compilation and just re-run make. As the target didn't change, the make process probably didn't recompile anything, and at testing everything worked fine, while in reality the PKGBUILD cound't produce the proper fix. This is because the configuration file location are passed to the C source code as compilation flags through this like in the Makefile: CONFCPPFLAGS = -DSYSCONFDIR='"$(sysconfdir)"' -DREL_SYSCONFDIR='"$(rel_sysconfdir)"' When rebuilding from scratch, without passing sysconfdir=/etc to make, we have: $ strings $(which imx_usb) | grep "imx-loader\.d" /usr/etc/imx-loader.d/ ../etc/imx-loader.d And when rebuilding from scratch and passing sysconfdir=/etc to make, we finally have: $ strings $(which imx_usb) | grep "imx-loader\.d" /etc/imx-loader.d/ ../../etc/imx-loader.d Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cf1b75be5c6..dd5c15fbe1ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = imx_usb_loader-git
pkgdesc = Tool to communicate with I.MX bootroms to execute code
pkgver = 0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/boundarydevices/imx_usb_loader
arch = armv7h
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index ca99ca04cd03..7c4030596ba1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=imx_usb_loader
pkgname=${_pkgname}-git
pkgver=0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Tool to communicate with I.MX bootroms to execute code"
arch=('armv7h' 'i686' 'x86_64')
url='https://github.com/boundarydevices/imx_usb_loader'
@@ -20,7 +20,7 @@ sha256sums=('SKIP')
build() {
cd "$srcdir/${_pkgname}"
- make
+ make sysconfdir=/etc
}
package(){