summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Marino2018-09-13 11:26:21 -0600
committerJose Marino2018-09-13 12:54:35 -0600
commita2e71946b5ee429571a50d89848f312af372b771 (patch)
tree8f2b78a543e4b0ca8d225998f69f764e4e48dc8a
parenta2baa4e4aa04cb817fb09a5b6e67d5648b63d44d (diff)
downloadaur-a2e71946b5ee429571a50d89848f312af372b771.tar.gz
install only required folders and files
The github source package comes with a lot of unnecessary stuff. We only need these 3 things: package.json app/ node_modules/
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24fd8a3ed690..4e2ae399eb4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,9 +37,10 @@ build() {
package() {
mkdir -p "$pkgdir"/usr/{lib/$pkgname,share/pixmaps}
+ mkdir -p "$pkgdir"/tmp
# Copy app to tmp folder, clean it up, and pack it with asar
- cp -ar $pkgname-$pkgver "$pkgdir/tmp"
+ cp -ar "$pkgname-$pkgver/"{app,node_modules,package.json} "$pkgdir/tmp"
find "$pkgdir/tmp/node_modules" \
-name "package.json" \
-exec sed -e "s|$srcdir/$pkgname|/usr/lib/$pkgname|" \