summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarek Galal2017-12-01 13:37:25 +0100
committerTarek Galal2017-12-01 13:37:54 +0100
commita2612d1c8350fcfea3a1018755b591b1cdfb675d (patch)
tree8ebdc2664d02f65bdfc75483708a6683b2ef521b
downloadaur-a2612d1c8350fcfea3a1018755b591b1cdfb675d.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29c2cc2da28e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = inception-android
+ pkgdesc = Hands-off auto-configuration tools for android devices
+ pkgver = 0.9.11
+ pkgrel = 1
+ url = https://github.com/tgalal/inception
+ arch = any
+ license = GPL3
+ makedepends = python2-setuptools
+ makedepends = gcc
+ depends = python2
+ depends = python2-argparse
+ depends = python2-dulwich
+ depends = android-dumpkey
+ depends = cpio
+ optdepends = jre8-openjdk-headless: signing packages
+ source = https://github.com/tgalal/inception/archive/0.9.11.tar.gz
+ md5sums = 54ef7cf0cc3c41263b0daee149348d05
+
+pkgname = inception-android
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2439b8697f4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Tarek Galal <tare2.galal@gmail.com>
+pkgname=inception-android
+pkgver=0.9.11
+pkgrel=1
+pkgdesc="Hands-off auto-configuration tools for android devices"
+arch=('any')
+url="https://github.com/tgalal/inception"
+license=('GPL3')
+depends=('python2' 'python2-argparse' 'python2-dulwich' 'android-dumpkey' 'cpio')
+makedepends=('python2-setuptools' 'gcc')
+optdepends=('jre8-openjdk-headless: signing packages')
+source=("https://github.com/tgalal/inception/archive/$pkgver.tar.gz")
+md5sums=('54ef7cf0cc3c41263b0daee149348d05')
+
+
+build() {
+ cd $srcdir/inception-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/inception-$pkgver
+ python2 setup.py install --prefix=/usr --root=$pkgdir --optimize=1
+}