summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Mendez2015-07-23 09:47:03 -0400
committerManuel Mendez2015-07-23 09:47:03 -0400
commit6341dbfcb6cb5f915690e20050a25587806c8b03 (patch)
tree683b9df09129b1545234596e3e2a374774ff7744
parent670cf8b4c6e0efab4fa39b9405a015080e7cac56 (diff)
downloadaur-6341dbfcb6cb5f915690e20050a25587806c8b03.tar.gz
add makedepend on llvm
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 429138cc40f9..0b36aeae714d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = include-what-you-use
pkgdesc = A tool for use with clang to analyze #includes in C and C++ source files
pkgver = 0.4
- pkgrel = 1
+ pkgrel = 2
epoch = 1
- url = http://code.google.com/p/include-what-you-use/
+ url = http://include-what-you-use.org
arch = i686
arch = x86_64
license = LLVM Release License
makedepends = clang>=3.6
makedepends = clang<=3.7
+ makedepends = llvm>=3.6
+ makedepends = llvm<=3.7
depends = clang>=3.6
depends = clang<=3.7
optdepends = python2
diff --git a/PKGBUILD b/PKGBUILD
index be1e1f90fbb1..92db98558b8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=include-what-you-use
epoch=1
pkgver=0.4
-pkgrel=1
+pkgrel=2
pkgdesc="A tool for use with clang to analyze #includes in C and C++ source files"
-url="http://code.google.com/p/include-what-you-use/"
+url="http://include-what-you-use.org"
license=('LLVM Release License')
source=(http://include-what-you-use.org/downloads/include-what-you-use-$pkgver.src.tar.gz)
sha1sums=('c1cff21519e201a03141421953efcbe027f4e52c')
arch=('i686' 'x86_64')
depends=('clang>=3.6' 'clang<=3.7')
-makedepends=('clang>=3.6' 'clang<=3.7')
+makedepends=('clang>=3.6' 'clang<=3.7' 'llvm>=3.6' 'llvm<=3.7')
optdepends=('python2')
build() {