summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Mendez2015-06-09 13:25:49 -0400
committerManuel Mendez2015-06-09 13:25:49 -0400
commita17df905fd8eb07402f72f7795284690ba0845bb (patch)
treec2f19cb0ca424107d4c04c961089bcce829b7d13
downloadaur-a17df905fd8eb07402f72f7795284690ba0845bb.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..429138cc40f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = include-what-you-use
+ pkgdesc = A tool for use with clang to analyze #includes in C and C++ source files
+ pkgver = 0.4
+ pkgrel = 1
+ epoch = 1
+ url = http://code.google.com/p/include-what-you-use/
+ arch = i686
+ arch = x86_64
+ license = LLVM Release License
+ makedepends = clang>=3.6
+ makedepends = clang<=3.7
+ depends = clang>=3.6
+ depends = clang<=3.7
+ optdepends = python2
+ source = http://include-what-you-use.org/downloads/include-what-you-use-0.4.src.tar.gz
+ sha1sums = c1cff21519e201a03141421953efcbe027f4e52c
+
+pkgname = include-what-you-use
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..68e71c9f0d5f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+.*
+!.gitignore
+include-what-you-use*.tar.gz
+include-what-you-use*.pkg.*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be1e1f90fbb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Manuel Mendez <mmendez534@gmail.com>
+
+pkgname=include-what-you-use
+epoch=1
+pkgver=0.4
+pkgrel=1
+pkgdesc="A tool for use with clang to analyze #includes in C and C++ source files"
+url="http://code.google.com/p/include-what-you-use/"
+license=('LLVM Release License')
+source=(http://include-what-you-use.org/downloads/include-what-you-use-$pkgver.src.tar.gz)
+sha1sums=('c1cff21519e201a03141421953efcbe027f4e52c')
+arch=('i686' 'x86_64')
+depends=('clang>=3.6' 'clang<=3.7')
+makedepends=('clang>=3.6' 'clang<=3.7')
+optdepends=('python2')
+
+build() {
+ cd $srcdir/$pkgname
+
+ cmake -DLLVM_PATH=/usr/lib -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ make
+ sed -i "s|^#!/usr/bin/python$|#!/usr/bin/python2|" fix_includes.py
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ make install DESTDIR=$pkgdir
+ install -Dm755 fix_includes.py "${pkgdir}/usr/bin/iwyu-fix_includes.py"
+}
+
+# vim:set ts=2 sw=2 et: