summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 18:13:49 +0100
committerBartłomiej Piotrowski2018-01-07 18:13:49 +0100
commit3287333066ef3b92a9209b8f565a92fcc384bc74 (patch)
treea2c3ab6273b8a8635b22fe1b03ff249cd710fe15
downloadaur-3287333066ef3b92a9209b8f565a92fcc384bc74.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
-rw-r--r--indent-2.2.11-LC_ALL.patch17
-rw-r--r--indent-2.2.11-decimal_format.patch98
-rw-r--r--indent-2.2.11-segfault.patch16
5 files changed, 200 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d661cf088f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = indent
+ pkgdesc = C language source code formatting program
+ pkgver = 2.2.11
+ pkgrel = 4
+ url = https://www.gnu.org/software/indent/
+ arch = x86_64
+ license = GPL3
+ makedepends = texi2html
+ depends = glibc
+ source = http://ftp.de.debian.org/debian/pool/main/i/indent/indent_2.2.11.orig.tar.gz
+ source = indent-2.2.11-segfault.patch
+ source = indent-2.2.11-LC_ALL.patch
+ source = indent-2.2.11-decimal_format.patch
+ sha1sums = 9b242528bbc4914464117c69ffae9df24d3fa4a7
+ sha1sums = 31a6dcd5edcac4decac81dbb52bc9415b8b148e4
+ sha1sums = 91b210b666de59ca44524288a4c1ebd213570daa
+ sha1sums = 2b7d5a725fe307ce81565f920a0a66b319b50c91
+
+pkgname = indent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3090fea5f548
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id: PKGBUILD 310007 2017-11-15 14:11:34Z foutrelis $
+# Maintainer:
+
+pkgname=indent
+pkgver=2.2.11
+pkgrel=4
+pkgdesc="C language source code formatting program"
+arch=('x86_64')
+url="https://www.gnu.org/software/indent/"
+license=('GPL3')
+depends=('glibc')
+makedepends=('texi2html')
+source=(http://ftp.de.debian.org/debian/pool/main/i/indent/${pkgname}_${pkgver}.orig.tar.gz
+ indent-2.2.11-segfault.patch
+ indent-2.2.11-LC_ALL.patch
+ indent-2.2.11-decimal_format.patch)
+sha1sums=('9b242528bbc4914464117c69ffae9df24d3fa4a7'
+ '31a6dcd5edcac4decac81dbb52bc9415b8b148e4'
+ '91b210b666de59ca44524288a4c1ebd213570daa'
+ '2b7d5a725fe307ce81565f920a0a66b319b50c91')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ../indent-2.2.11-segfault.patch
+
+ # http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=205692
+ patch -Np1 -i ../indent-2.2.11-LC_ALL.patch
+
+ # https://lists.gnu.org/archive/html/bug-indent/2011-08/msg00000.html
+ patch -Np1 -i ../indent-2.2.11-decimal_format.patch
+
+ sed -i 's/-number/-number-sections/' doc/Makefile.in
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}/regression"
+ make test
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" docdir=/usr/share/doc/indent install
+}
diff --git a/indent-2.2.11-LC_ALL.patch b/indent-2.2.11-LC_ALL.patch
new file mode 100644
index 000000000000..0ffe56d3c921
--- /dev/null
+++ b/indent-2.2.11-LC_ALL.patch
@@ -0,0 +1,17 @@
+From: Santiago Vila <sanvila@debian.org>
+Subject: setlocale using LC_ALL, not LC_MESSAGES
+Bug-Debian: http://bugs.debian.org/205692
+
+--- a/src/indent.c
++++ b/src/indent.c
+@@ -1008,8 +1008,8 @@
+ BOOLEAN using_stdin = false;
+ exit_values_ty exit_status;
+
+-#if defined (HAVE_SETLOCALE) && defined (HAVE_LC_MESSAGES) && defined (HAVE_LCCTYPES)
+- setlocale(LC_MESSAGES, "");
++#if defined (HAVE_SETLOCALE)
++ setlocale(LC_ALL, "");
+ #endif
+ bindtextdomain(PACKAGE, LOCALEDIR);
+ textdomain(PACKAGE);
diff --git a/indent-2.2.11-decimal_format.patch b/indent-2.2.11-decimal_format.patch
new file mode 100644
index 000000000000..ea34d0ea713e
--- /dev/null
+++ b/indent-2.2.11-decimal_format.patch
@@ -0,0 +1,98 @@
+From ff47ab3b90333bdfaa40b86cb548e92a01787345 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Thu, 25 Aug 2011 11:26:24 +0200
+Subject: [PATCH] Do not split decimal float suffix from constant
+
+N1312 draft of ISO/IEC WDTR24732 defines additional floating types
+with given suffixes:
+
+_Decimal32 DF, df
+_Decimal64 DD, dd
+_Decimal128 DL, dl
+
+These suffixes must stick on numeric part of the constant as classic
+float or long float does.
+---
+ regression/TEST | 3 ++-
+ regression/input/float-constant-suffix.c | 13 +++++++++++++
+ regression/standard/float-constant-suffix.c | 13 +++++++++++++
+ src/lexi.c | 9 +++++++++
+ 4 files changed, 37 insertions(+), 1 deletions(-)
+ create mode 100644 regression/input/float-constant-suffix.c
+ create mode 100644 regression/standard/float-constant-suffix.c
+
+diff --git a/regression/TEST b/regression/TEST
+index c860ef2..1402ddf 100755
+--- a/regression/TEST
++++ b/regression/TEST
+@@ -35,7 +35,8 @@ EXAMPLES="do.c else.c for.c func-def.c lshift.c ncs.c \
+
+ BUGS="case-label.c one-line-1.c one-line-2.c one-line-3.c \
+ one-line-4.c struct-decl.c sizeof-in-while.c line-break-comment.c \
+- macro.c enum.c elif.c nested.c wrapped-string.c minus_predecrement.c"
++ macro.c enum.c elif.c nested.c wrapped-string.c minus_predecrement.c \
++ float-constant-suffix.c"
+
+ INDENTSRC="args.c backup.h backup.c dirent_def.h globs.c indent.h \
+ indent.c indent_globs.h io.c lexi.c memcpy.c parse.c pr_comment.c \
+diff --git a/regression/input/float-constant-suffix.c b/regression/input/float-constant-suffix.c
+new file mode 100644
+index 0000000..58f5310
+--- /dev/null
++++ b/regression/input/float-constant-suffix.c
+@@ -0,0 +1,13 @@
++float foo = 1.0F;
++float foo = 1.0f;
++double foo = 1.0;
++double foo = 1.0;
++long double foo = 1.0L;
++long double foo = 1.0l;
++
++_Decimal32 foo = 1.0DF;
++_Decimal32 foo = 1.0df;
++_Decimal64 foo = 1.0DD;
++_Decimal64 foo = 1.0dd;
++_Decimal128 foo = 1.0DL;
++_Decimal128 foo = 1.0dl;
+diff --git a/regression/standard/float-constant-suffix.c b/regression/standard/float-constant-suffix.c
+new file mode 100644
+index 0000000..58f5310
+--- /dev/null
++++ b/regression/standard/float-constant-suffix.c
+@@ -0,0 +1,13 @@
++float foo = 1.0F;
++float foo = 1.0f;
++double foo = 1.0;
++double foo = 1.0;
++long double foo = 1.0L;
++long double foo = 1.0l;
++
++_Decimal32 foo = 1.0DF;
++_Decimal32 foo = 1.0df;
++_Decimal64 foo = 1.0DD;
++_Decimal64 foo = 1.0dd;
++_Decimal128 foo = 1.0DL;
++_Decimal128 foo = 1.0dl;
+diff --git a/src/lexi.c b/src/lexi.c
+index abc2bfa..eafb65e 100644
+--- a/src/lexi.c
++++ b/src/lexi.c
+@@ -330,6 +330,15 @@ extern codes_ty lexi(void)
+ {
+ buf_ptr++;
+ }
++ else if (*buf_ptr == 'D' || *buf_ptr == 'd')
++ {
++ if (buf_ptr[1] == 'F' || buf_ptr[1] == 'f' ||
++ buf_ptr[1] == 'D' || buf_ptr[1] == 'd' ||
++ buf_ptr[1] == 'L' || buf_ptr[1] == 'l')
++ {
++ buf_ptr+=2;
++ }
++ }
+ else
+ {
+ while (*buf_ptr == 'U' || *buf_ptr == 'u' || *buf_ptr == 'L' || *buf_ptr == 'l')
+--
+1.7.6
+
diff --git a/indent-2.2.11-segfault.patch b/indent-2.2.11-segfault.patch
new file mode 100644
index 000000000000..e91922480951
--- /dev/null
+++ b/indent-2.2.11-segfault.patch
@@ -0,0 +1,16 @@
+--- a/man/texinfo2man.c
++++ b/man/texinfo2man.c
+@@ -287,6 +287,13 @@
+ char buf[1024];
+ int line_no = 0;
+
++ if (argc != 3)
++ {
++ fprintf(stderr, "Usage: %s <man template> <info file>\n", argv[0]);
++ fprintf(stderr, " The man page will be written to stdout.\n");
++ return -1;
++ }
++
+ texinfoname = argv[2];
+
+ in = fopen (argv[2], "r");