summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroberon20072015-09-22 00:07:45 +0200
committeroberon20072015-09-22 00:07:45 +0200
commit4a2506f0df5732c8b3cf301dc4354dc0fac16802 (patch)
treeb7c7cf958b225ad1f914680736aa9b40c8121f94
downloadaur-4a2506f0df5732c8b3cf301dc4354dc0fac16802.tar.gz
new
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f8b6ae65925
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = indicator-application-gtk2
+ pkgdesc = Indicator to take menus from applications and place them in the panel (GTK+ 2 library for Xfce/LXDE)
+ pkgver = 12.10.0.1
+ pkgrel = 2
+ url = https://launchpad.net/indicators-gtk2
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libappindicator
+ depends = indicator-application
+ depends = libdbusmenu-gtk2
+ depends = libindicator
+ options = !libtool
+ source = https://launchpad.net/indicators-gtk2/indicator-application-gtk2/i-a-12.10.0.1/+download/indicator-application-12.10.0.1.tar.gz
+ md5sums = 1d10bf69a026acd636f1b99d4cd7dce9
+
+pkgname = indicator-application-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e444de0a0e54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Bernhard Landauer <oberon@manjaro.org>
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=indicator-application-gtk2
+_pkgname=indicator-application
+pkgver=12.10.0.1
+pkgrel=2
+pkgdesc="Indicator to take menus from applications and place them in the panel (GTK+ 2 library for Xfce/LXDE)"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/indicators-gtk2"
+license=('GPL')
+depends=('indicator-application' 'libdbusmenu-gtk2' 'libindicator')
+makedepends=('libappindicator')
+options=('!libtool')
+source=(https://launchpad.net/indicators-gtk2/$pkgname/i-a-$pkgver/+download/$_pkgname-$pkgver.tar.gz)
+md5sums=('1d10bf69a026acd636f1b99d4cd7dce9')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ sed -i 's/-Werror//' {src,tests}/Makefile.{am,in}
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ make -C src DESTDIR="$pkgdir/" install-applicationlibLTLIBRARIES
+}