summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2015-08-15 14:01:10 +0200
committerJohannes Dewender2015-08-15 14:01:10 +0200
commitdf17fd0a8e8cb6d4b5cc5db976d22f1ce1cd7864 (patch)
tree98f6f7582869f6ea18e342931a3a288dd61907a1
downloadaur-df17fd0a8e8cb6d4b5cc5db976d22f1ce1cd7864.tar.gz
create with indicator-keylock 3.0.2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
-rw-r--r--indicator-keylock.install16
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b99c214ad19e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = indicator-keylock
+ pkgdesc = An indicator that displays the status of the keyboard lock keys
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://launchpad.net/indicator-keylock/
+ install = indicator-keylock.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = gconf
+ depends = libappindicator-gtk3
+ depends = libunique3
+ depends = libnotify
+ depends = libx11
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ optdepends = notification-daemon: for notificiations
+ source = http://archive.ubuntu.com/ubuntu/pool/universe/i/indicator-keylock/indicator-keylock_3.0.2.tar.xz
+ md5sums = 8e9f20e25cdadaf5ccc8174e3b60bcf4
+
+pkgname = indicator-keylock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1c8db9e1f38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Johannes Dewender arch at JonnyJD dot net
+pkgname=indicator-keylock
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="An indicator that displays the status of the keyboard lock keys"
+arch=('x86_64' 'i686')
+url="https://launchpad.net/indicator-keylock/"
+license=('GPL3')
+depends=('gconf' 'libappindicator-gtk3' 'libunique3' 'libnotify' 'libx11'
+ 'desktop-file-utils' 'gtk-update-icon-cache')
+makedepends=()
+optdepends=('notification-daemon: for notificiations')
+backup=()
+options=()
+install=indicator-keylock.install
+source=("http://archive.ubuntu.com/ubuntu/pool/universe/i/$pkgname/${pkgname}_$pkgver.tar.xz")
+md5sums=('8e9f20e25cdadaf5ccc8174e3b60bcf4')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ # the tarball is plain from the repository, without configure
+ ./autogen.sh
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-schemas-compile
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/indicator-keylock.install b/indicator-keylock.install
new file mode 100644
index 000000000000..d08965617571
--- /dev/null
+++ b/indicator-keylock.install
@@ -0,0 +1,16 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}