summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-12-14 21:12:59 +0900
committerQue Quotion2017-12-14 21:12:59 +0900
commit1267f7af8057ed94d40fc0b0a059f548a88b476e (patch)
tree381208953350aef1c8b60dec92c8d3bb5a1d405c
parente48e122ec4c327a0b08a558bcd6a3d1ebb3f807a (diff)
downloadaur-1267f7af8057ed94d40fc0b0a059f548a88b476e.tar.gz
Use cpuinfo min/max for more relative icon display
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--indicator.py.patch4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2beb768cef9f..066da6b6f131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu May 25 11:41:37 UTC 2017
+# Thu Dec 14 12:12:02 UTC 2017
pkgbase = indicator-powersave
pkgdesc = User discretion power managment utility forked from CPU frequency indicator (bzr version)
pkgver = r98.8
diff --git a/PKGBUILD b/PKGBUILD
index 2c9fce39f937..a0ca88cc328f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,7 +33,7 @@ sha512sums=('SKIP'
pkgver() {
cd indicator-cpufreq
- printf "r%s" "$(bzr revno).8"
+ printf "r%s" "$(bzr revno).9"
}
prepare() {
diff --git a/indicator.py.patch b/indicator.py.patch
index a11151568c82..bdc27a50b250 100644
--- a/indicator.py.patch
+++ b/indicator.py.patch
@@ -154,9 +154,9 @@
- fmin, fmax, governor = cpufreq.get_policy(self.cpus[0])
+ govFile = open("/sys/devices/system/cpu/cpufreq/policy0/scaling_governor", 'r')
+ governor = govFile.readline().strip("\n")
-+ fmnFile = open("/sys/devices/system/cpu/cpufreq/policy0/scaling_min_freq", 'r')
++ fmnFile = open("/sys/devices/system/cpu/cpufreq/policy0/cpuinfo_min_freq", 'r')
+ fmin = int(fmnFile.readline().strip("\n"))
-+ fmxFile = open("/sys/devices/system/cpu/cpufreq/policy0/scaling_max_freq", 'r')
++ fmxFile = open("/sys/devices/system/cpu/cpufreq/policy0/cpuinfo_max_freq", 'r')
+ fmax = int(fmxFile.readline().strip("\n"))
# use the highest freq among cores for display
- freq = max([cpufreq.get_freq_kernel(cpu) for cpu in self.cpus])