summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2017-03-30 01:10:52 +0900
committerQue Quotion2017-03-30 01:10:52 +0900
commitb9a4e5a996e2b57d57125d9f4a6b6d376c39502b (patch)
treeac0c022b41c9a16e39b1d12fb001a7d54275ff85
parent290bc56bfa9d9d75b63fa9aa0b9bdea9814af796 (diff)
downloadaur-b9a4e5a996e2b57d57125d9f4a6b6d376c39502b.tar.gz
Less unnecessary waiting (only wait when we have other tasks to do)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xthrottle12
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65faabbac7a3..2c9519ae2126 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Mar 26 14:46:54 UTC 2017
+# Wed Mar 29 16:09:17 UTC 2017
pkgbase = indicator-powersave
pkgdesc = User discretion power managment utility forked from CPU frequency indicator (bzr version)
- pkgver = r98.7
- pkgrel = 2
+ pkgver = r98.6
+ pkgrel = 1
url = https://launchpad.net/indicator-cpufreq
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 550c24cad832..59376a5a82b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Xiao-Long Chen <chenxiaolongcxl.epac.to>
pkgname=indicator-powersave
-pkgver=r98.7
-pkgrel=2
+pkgver=r98.6
+pkgrel=1
pkgdesc="User discretion power managment utility forked from CPU frequency indicator (bzr version)"
arch=('i686' 'x86_64')
url="https://launchpad.net/indicator-cpufreq"
diff --git a/throttle b/throttle
index 332d91075f5d..3435e5ab5e06 100755
--- a/throttle
+++ b/throttle
@@ -144,11 +144,11 @@ while (( "$#" )); do
[[ -n "$(command -v nvidia-settings)" ]] && \
DISPLAY=":0.0" nvidia-settings -a [gpu:0]/GPUPowerMizerMode="${NVPM}" > /dev/null &
- wait # Hey, let's stop! :) *stops* ... YAY! =D
shift
unset GOVERNOR XPSTURBO HYPERTHREADS ENERGYPERF BACKLIGHT LAPTOP DIRTYWBC NMIDOG \
POLICY APM AAM CONTROL AUTOSUSPEND POWERSAVE CONTROLLER \
WLPOWERSAVE WOLA WOLB LEDBRIGHT NVPM
+ [[ -n "${1}" ]] && wait # Hey, let's stop! :) *stops* ... YAY! =D
;;
ht*)
case "${1}" in \
@@ -163,8 +163,8 @@ while (( "$#" )); do
for i in /sys/devices/system/cpu/cpu*/online; do [[ "$(printf "${i}" | tr -cd [:digit:])" -ge "${CORES}" ]] && \
printf "${HYPERTHREADS}" > "${i}" & done &
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
- wait
unset HYPERTHREADS SHIFT
+ [[ -n "${1}" ]] && wait
;;
gov*)
case "${1}" in \
@@ -179,8 +179,8 @@ while (( "$#" )); do
for i in /sys/bus/cpu/drivers/processor/cpu*/cpufreq/scaling_governor; do \
printf "${GOVERNOR}" > "${i}" & done &
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
- wait
unset GOVERNOR SHIFT
+ [[ -n "${1}" ]] && wait
;;
turbo*)
case "${1}" in \
@@ -195,8 +195,8 @@ while (( "$#" )); do
[[ -f /sys/devices/system/cpu/intel_pstate/no_turbo ]] && \
printf "${XPSTURBO}" > /sys/devices/system/cpu/intel_pstate/no_turbo &
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
- wait
unset XPSTURBO SHIFT
+ [[ -n "${1}" ]] && wait
;;
backlight)
case "${2}" in \
@@ -208,8 +208,8 @@ while (( "$#" )); do
for i in /sys/class/backlight/acpi_video*/brightness; do \
printf "${BACKLIGHT}" > "${i}" & done &
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
- wait
unset BACKLIGHT SHIFT
+ [[ -n "${1}" ]] && wait
;;
gpu*)
case "${1}" in \
@@ -225,8 +225,8 @@ while (( "$#" )); do
printf "nvidia-settings not found; only nvidia currently supported" || \
DISPLAY=":0.0" nvidia-settings -a [gpu:0]/GPUPowerMizerMode="${NVPM}" > /dev/null &
[[ -n "${SHIFT}" ]] && shift "${SHIFT}" || shift
- wait
unset NVPM SHIFT
+ [[ -n "${1}" ]] && wait
;;
check)
printf "\nHyperthreads\n/sys/devices/system/cpu/cpu*/online\n"