summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiao-Long Chen2015-06-08 20:19:51 -0400
committerXiao-Long Chen2015-06-08 20:19:51 -0400
commit219cd6afb0129f532db773317daa32497cb7293c (patch)
treea0fbd839d0d51f520bbc61112b7d8e595f58cb6f
downloadaur-219cd6afb0129f532db773317daa32497cb7293c.tar.gz
Import from old AUR
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD25
-rw-r--r--indicator-remindor.install12
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7308f56f1a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = indicator-remindor
+ pkgdesc = Schedule reminders easily from an indicator
+ pkgver = 14.06
+ pkgrel = 1
+ url = https://launchpad.net/indicator-remindor
+ install = indicator-remindor.install
+ arch = any
+ license = GPL
+ makedepends = python2-distutils-extra
+ depends = gstreamer0.10
+ depends = gtk3
+ depends = libappindicator3
+ depends = libnotify
+ depends = python2-dateutil
+ depends = python2-dbus
+ depends = python2-feedparser
+ depends = python2-requests
+ depends = remindor-common
+ optdepends = yelp: Help stuff
+ source = http://ppa.launchpad.net/bhdouglass/indicator-remindor/ubuntu/pool/main/i/indicator-remindor/indicator-remindor_14.06-0ubuntu1~trusty.tar.gz
+ sha512sums = 6e6cb421d24d51c8ef94a81c65b0ce32f076c6ac379b441b2ff66303507b7bcc3999f08a22c45f01bcfdb986db4bf4a4d58cf76185d468c1e57d63ee61d1b914
+
+pkgname = indicator-remindor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e2ca3d75601
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+# vercheck-pkgbuild: auto
+# vercheck-ppa: name=${pkgname}, url=ppa:bhdouglass/indicator-remindor, native
+
+pkgname=indicator-remindor
+pkgver=14.06
+_ppa_rel=0ubuntu1~trusty
+pkgrel=1
+pkgdesc="Schedule reminders easily from an indicator"
+arch=(any)
+url="https://launchpad.net/indicator-remindor"
+license=(GPL)
+depends=(gstreamer0.10 gtk3 libappindicator3 libnotify python2-dateutil
+ python2-dbus python2-feedparser python2-requests remindor-common)
+makedepends=(python2-distutils-extra)
+optdepends=('yelp: Help stuff')
+install=indicator-remindor.install
+source=("http://ppa.launchpad.net/bhdouglass/indicator-remindor/ubuntu/pool/main/i/indicator-remindor/indicator-remindor_${pkgver}-${_ppa_rel}.tar.gz")
+sha512sums=('6e6cb421d24d51c8ef94a81c65b0ce32f076c6ac379b441b2ff66303507b7bcc3999f08a22c45f01bcfdb986db4bf4a4d58cf76185d468c1e57d63ee61d1b914')
+
+package() {
+ cd "${pkgname}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}
diff --git a/indicator-remindor.install b/indicator-remindor.install
new file mode 100644
index 000000000000..b45d8b5e53f1
--- /dev/null
+++ b/indicator-remindor.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor/
+ glib-compile-schemas usr/share/glib-2.0/schemas/
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}