summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-06-26 11:10:35 +0200
committerValHue2015-06-26 11:10:35 +0200
commit7755c94d5355ed06437f4c234394fa5fb1fc0f46 (patch)
tree208b6aab164fb3a90554c2897bfb51144c2526c4
parentb44d811f01caa2338c811d0b2fca2d3a9b3d5922 (diff)
downloadaur-7755c94d5355ed06437f4c234394fa5fb1fc0f46.tar.gz
Initial import
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD37
-rw-r--r--indicator-sound.install3
3 files changed, 19 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b005bc57b2b5..dc501f5adf0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,19 +6,19 @@ pkgbase = indicator-sound
install = indicator-sound.install
arch = i686
arch = x86_64
- groups = pantheon
- groups = pantheon-unstable
license = GPL
makedepends = intltool
makedepends = vala
depends = ido
depends = libdbusmenu-gtk3
- depends = libgee
+ depends = libgee06
depends = libindicator-gtk3
depends = libpulse
depends = libnotify
source = https://launchpad.net/indicator-sound/12.10/12.10.1/+download/indicator-sound-12.10.1.tar.gz
+ source = http://pkgbuild.com/~bgyorgy/sources/indicator-sound-translations-20130310.tar.gz
sha256sums = d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6
+ sha256sums = 7830a7bf49b86f92558ad4bc1499db4e0c8680b0aa31d046262d8169b0bafcd2
pkgname = indicator-sound
diff --git a/PKGBUILD b/PKGBUILD
index c7504311593b..ec3827367395 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,42 +6,35 @@ pkgver=12.10.1
pkgrel=5
pkgdesc='A unified sound menu'
arch=('i686' 'x86_64')
-url='https://launchpad.net/indicator-sound'
+url="https://launchpad.net/${pkgname}"
license=('GPL')
-groups=('pantheon' 'pantheon-unstable')
-depends=('ido' 'libdbusmenu-gtk3' 'libgee' 'libindicator-gtk3' 'libpulse'
- 'libnotify')
+depends=('ido' 'libdbusmenu-gtk3' 'libgee06' 'libindicator-gtk3' 'libpulse' 'libnotify')
makedepends=('intltool' 'vala')
-install='indicator-sound.install'
-source=("https://launchpad.net/indicator-sound/${pkgver%.*}/${pkgver}/+download/indicator-sound-${pkgver}.tar.gz")
-sha256sums=('d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6')
+install="${pkgname}.install"
+source=("${url}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
+ "http://pkgbuild.com/~bgyorgy/sources/${pkgname}-translations-20130310.tar.gz")
+sha256sums=('d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6'
+ '7830a7bf49b86f92558ad4bc1499db4e0c8680b0aa31d046262d8169b0bafcd2')
prepare() {
- cd indicator-sound-${pkgver}
+ cd ${pkgname}-${pkgver}
- sed 's/gee-1.0/gee-0.8/' -i configure.ac src/Makefile.{am,in}
- sed 's/rhythmbox/noise-player/g' -i data/com.canonical.indicator.sound.gschema.xml
-
- autoreconf -fi
+# Install updated language files
+ rename ${pkgname}- '' ../po/${pkgname}-*.po
+ mv -f -t po ../po/*
+ printf "%s\n" po/*.po | sed -e 's/po\///g' -e 's/\.po//g' >po/LINGUAS
}
build() {
- cd indicator-sound-${pkgver}
+ cd ${pkgname}-${pkgver}
export CFLAGS="$CFLAGS -Wno-deprecated-declarations"
-
- ./configure \
- --prefix='/usr' \
- --localstatedir='/var' \
- --libexecdir='/usr/lib/indicator-sound' \
- --sysconfdir='/etc' \
- --disable-schemas-compile \
- --disable-static
+ ./configure --prefix='/usr' --sysconfdir='/etc' --localstatedir='/var' --libexecdir="/usr/lib/${pkgname}" --disable-{schemas-compile,static}
make
}
package() {
- cd indicator-sound-${pkgver}
+ cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
diff --git a/indicator-sound.install b/indicator-sound.install
index 04c22f099e0a..43fe00f8d2e2 100644
--- a/indicator-sound.install
+++ b/indicator-sound.install
@@ -1,6 +1,5 @@
post_install() {
- glib-compile-schemas /usr/share/glib-2.0/schemas
- gtk-update-icon-cache -ftq /usr/share/libindicator/icons/hicolor
+ glib-compile-schemas usr/share/glib-2.0/schemas
}
post_upgrade() {