summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:02:33 +0200
committerMaxime Gauduin2015-06-09 12:02:33 +0200
commitb44d811f01caa2338c811d0b2fca2d3a9b3d5922 (patch)
tree67007a0257b0d3a4cd8a068418173c57c6d9de61
downloadaur-b44d811f01caa2338c811d0b2fca2d3a9b3d5922.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD55
-rw-r--r--indicator-sound.install14
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b005bc57b2b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = indicator-sound
+ pkgdesc = A unified sound menu
+ pkgver = 12.10.1
+ pkgrel = 5
+ url = https://launchpad.net/indicator-sound
+ install = indicator-sound.install
+ arch = i686
+ arch = x86_64
+ groups = pantheon
+ groups = pantheon-unstable
+ license = GPL
+ makedepends = intltool
+ makedepends = vala
+ depends = ido
+ depends = libdbusmenu-gtk3
+ depends = libgee
+ depends = libindicator-gtk3
+ depends = libpulse
+ depends = libnotify
+ source = https://launchpad.net/indicator-sound/12.10/12.10.1/+download/indicator-sound-12.10.1.tar.gz
+ sha256sums = d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6
+
+pkgname = indicator-sound
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..0779691d7321
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+pkgname=('indicator-sound')
+builddeps=('ido' 'libindicator-gtk3')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7504311593b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Balló György <ballogyor+arch@gmail.com>
+
+pkgname=indicator-sound
+pkgver=12.10.1
+pkgrel=5
+pkgdesc='A unified sound menu'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/indicator-sound'
+license=('GPL')
+groups=('pantheon' 'pantheon-unstable')
+depends=('ido' 'libdbusmenu-gtk3' 'libgee' 'libindicator-gtk3' 'libpulse'
+ 'libnotify')
+makedepends=('intltool' 'vala')
+install='indicator-sound.install'
+source=("https://launchpad.net/indicator-sound/${pkgver%.*}/${pkgver}/+download/indicator-sound-${pkgver}.tar.gz")
+sha256sums=('d3ae4e8a9e2bac6f9098e617364aba1ddca15ee118d5aa89ae85d0a1f3371af6')
+
+prepare() {
+ cd indicator-sound-${pkgver}
+
+ sed 's/gee-1.0/gee-0.8/' -i configure.ac src/Makefile.{am,in}
+ sed 's/rhythmbox/noise-player/g' -i data/com.canonical.indicator.sound.gschema.xml
+
+ autoreconf -fi
+}
+
+build() {
+ cd indicator-sound-${pkgver}
+
+ export CFLAGS="$CFLAGS -Wno-deprecated-declarations"
+
+ ./configure \
+ --prefix='/usr' \
+ --localstatedir='/var' \
+ --libexecdir='/usr/lib/indicator-sound' \
+ --sysconfdir='/etc' \
+ --disable-schemas-compile \
+ --disable-static
+ make
+}
+
+package() {
+ cd indicator-sound-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+
+# Fix icon names to provide the playlist icon
+ install -dm 755 "${pkgdir}"/usr/share/libindicator/icons/hicolor/{16x16,scalable}/mimetypes
+ mv "${pkgdir}"/usr/share/libindicator/icons/hicolor/16x16/{status/sound-icon.png,mimetypes/playlist.png}
+ mv "${pkgdir}"/usr/share/libindicator/icons/hicolor/scalable/{status/sound-icon.svg,mimetypes/playlist.svg}
+ rm -r "${pkgdir}"/usr/share/libindicator/icons/hicolor/{16x16,scalable}/status
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/indicator-sound.install b/indicator-sound.install
new file mode 100644
index 000000000000..04c22f099e0a
--- /dev/null
+++ b/indicator-sound.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq /usr/share/libindicator/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: