summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHomer Xing2020-07-10 18:27:41 -0700
committerHomer Xing2020-07-10 18:45:59 -0700
commit1fe4a324b7622fe4d683f3e5b306d006188edd34 (patch)
tree0561ec643d360476f084a512b68f6f3de2cece00
parentb17ebd6586d25655b62c152d142b149f71f45100 (diff)
downloadaur-1fe4a324b7622fe4d683f3e5b306d006188edd34.tar.gz
version 0.8.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6f91534181b..875a157ecd72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = indicator-sysmonitor-bzr
- pkgdesc = Show cpu and memory usage and also various temperature sensors.
- pkgver = 0.8.1
- pkgrel = 1
+ pkgdesc = An Application Indicator showing cpu temperature, memory, network speed, cpu usage, public IP address and internet connection status.
+ pkgver = 0.8.2
+ pkgrel = 0
url = https://launchpad.net/indicator-sysmonitor
- arch = i686
- arch = x86_64
- license = GPL
- depends = libindicator3
- depends = python2-psutil
+ arch = any
+ license = GPL3
+ makedepends = breezy
+ makedepends = python-dulwich
+ depends = libappindicator-gtk3
+ depends = python-psutil
depends = python
- depends = bzr
- optdepends = lm_sensors
- optdepends = gnu-netcat
- optdepends = hddtemp
pkgname = indicator-sysmonitor-bzr
diff --git a/PKGBUILD b/PKGBUILD
index 2b4d44415e92..9bdc4f40502f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,32 @@
# Contributor: Lael Guillemenot <zeppelinlg@gmail.com>
pkgname=indicator-sysmonitor-bzr
-pkgver=0.8.1
-pkgrel=1
-pkgdesc="Show cpu and memory usage and also various temperature sensors."
-arch=('i686' 'x86_64')
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="An Application Indicator showing cpu temperature, memory, network speed, cpu usage, public IP address and internet connection status."
+arch=('any')
url="https://launchpad.net/indicator-sysmonitor"
-license=('GPL')
-depends=('libindicator3' 'python2-psutil' 'python' 'bzr')
-makedepends=()
-optdepends=('lm_sensors' 'gnu-netcat' 'hddtemp')
+license=('GPL3')
+depends=('libappindicator-gtk3' 'python-psutil' 'python')
+makedepends=('breezy' 'python-dulwich')
+optdepends=()
_bzrbranch=lp:indicator-sysmonitor
_bzrmod=indicator-sysmonitor
build() {
cd ${srcdir}
-
- msg "Connecting to the server...."
-
- if [ ! -d ./${_bzrmod} ]; then
- bzr co ${_bzrbranch} ${_bzrmod}
- else
- bzr up ${_bzrmod}
+ if [ -e ${_bzrmod} ]; then
+ rm -rf ${_bzrmod}
fi
+ bzr co ${_bzrbranch} ${_bzrmod}
}
package() {
cd ${srcdir}/${_bzrmod}
- install -Dm755 ${srcdir}/${_bzrmod}/indicator-sysmonitor \
- ${pkgdir}/usr/bin/indicator-sysmonitor
- install -Dm644 ${srcdir}/${_bzrmod}/indicator-sysmonitor.desktop \
- ${pkgdir}/usr/share/applications/indicator-sysmonitor.desktop
+ make DESTDIR="${pkgdir}" install
+
+ python -m compileall -d '/' "${pkgdir}/"
+ python -O -m compileall -d '/' "${pkgdir}/"
}