summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaël Guillemenot2015-06-11 15:48:49 +0200
committerLaël Guillemenot2015-06-11 15:48:49 +0200
commit84926f147c5645660104090a6156351b42d5e0b9 (patch)
tree028d93391c183f6d56090623aa7851e91555ad9e
downloadaur-84926f147c5645660104090a6156351b42d5e0b9.tar.gz
Récupération en provenance de aur
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
-rw-r--r--python2.patch8
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bdb3e359d51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = indicator-sysmonitor-bzr
+ pkgdesc = Show cpu and memory usage and also various temperature sensors.
+ pkgver = 0.4.1
+ pkgrel = 4
+ url = https://launchpad.net/indicator-sysmonitor
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libindicator3
+ depends = python2-psutil
+ depends = python
+ depends = bzr
+ optdepends = lm_sensors
+ optdepends = gnu-netcat
+ optdepends = hddtemp
+ source = python2.patch
+ md5sums = fcaed89339fe394ddbcc161157fdb490
+
+pkgname = indicator-sysmonitor-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db262f3ffc08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Lael Guillemenot <zeppelinlg@gmail.com>
+
+pkgname=indicator-sysmonitor-bzr
+pkgver=0.4.1
+pkgrel=4
+pkgdesc="Show cpu and memory usage and also various temperature sensors."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/indicator-sysmonitor"
+license=('GPL')
+depends=('libindicator3' 'python2-psutil' 'python' 'bzr')
+makedepends=()
+optdepends=('lm_sensors' 'gnu-netcat' 'hddtemp')
+source=(python2.patch)
+md5sums=('fcaed89339fe394ddbcc161157fdb490')
+
+_bzrbranch=lp:indicator-sysmonitor
+_bzrmod=indicator-sysmonitor
+
+build() {
+ cd ${srcdir}
+
+ msg "Connecting to the server...."
+
+ if [ ! -d ./${_bzrmod} ]; then
+ bzr co ${_bzrbranch} ${_bzrmod}
+ else
+ bzr up ${_bzrmod}
+ fi
+
+ patch -p1 < "$srcdir/python2.patch"
+}
+
+package() {
+ cd ${srcdir}/${_bzrmod}
+ install -Dm755 ${srcdir}/${_bzrmod}/indicator-sysmonitor \
+ ${pkgdir}/usr/bin/indicator-sysmonitor
+
+ install -Dm644 ${srcdir}/${_bzrmod}/indicator-sysmonitor.desktop \
+ ${pkgdir}/usr/share/applications/indicator-sysmonitor.desktop
+}
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..6bb2b887d2ea
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,8 @@
+--- src/indicator-sysmonitor.orig/indicator-sysmonitor 2012-08-23 22:33:49.206770349 +0200
++++ src/indicator-sysmonitor/indicator-sysmonitor 2012-08-23 22:31:50.366486753 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ # coding: utf-8
+ #
+ # A simple indicator applet displaying cpu and memory information