summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Broda2018-01-30 13:24:04 +0100
committerRobin Broda2018-01-30 13:24:04 +0100
commit0d99c0b6cb1791cb07cc396520ea58900876282a (patch)
treef863945c77977eb071bdf1fedac1b059518d32fd
downloadaur-0d99c0b6cb1791cb07cc396520ea58900876282a.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0377bbb0c91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = indicator-sysmonitor-git
+ pkgdesc = A configurable system monitoring applet
+ pkgver = r90.f5f5f6f
+ pkgrel = 7
+ url = https://github.com/fossfreedom/indicator-sysmonitor
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = libappindicator-gtk3
+ depends = python
+ depends = python-psutil
+ provides = indicator-sysmonitor
+ conflicts = indicator-sysmonitor
+ source = git+https://github.com/fossfreedom/indicator-sysmonitor.git
+ source = https://github.com/fossfreedom/indicator-sysmonitor/pull/80.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = indicator-sysmonitor-budgie-git
+
+pkgname = indicator-sysmonitor-appindicator-git
+ depends = python
+ depends = python-psutil
+ depends = libappindicator-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ab567d6f77a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Robin Broda <robin at broda dot me>
+
+_pkgbase=indicator-sysmonitor
+pkgbase="${_pkgbase}-git"
+pkgname=("${_pkgbase}-budgie-git" "${_pkgbase}-appindicator-git")
+pkgver=r90.f5f5f6f
+pkgrel=7
+pkgdesc='A configurable system monitoring applet'
+arch=('any')
+url='https://github.com/fossfreedom/indicator-sysmonitor'
+license=('GPL3')
+conflicts=('indicator-sysmonitor')
+provides=('indicator-sysmonitor')
+depends=('python' 'python-psutil')
+makedepends=('git' 'libappindicator-gtk3')
+source=('git+https://github.com/fossfreedom/indicator-sysmonitor.git'
+ 'https://github.com/fossfreedom/indicator-sysmonitor/pull/80.patch')
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "${_pkgbase}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_pkgbase}"
+
+ patch Makefile "${srcdir}/80.patch"
+}
+
+package_indicator-sysmonitor-budgie-git() {
+ cd "${_pkgbase}"
+ make DESTDIR="${pkgdir}" installbudgie
+}
+
+package_indicator-sysmonitor-appindicator-git() {
+ depends+=('libappindicator-gtk3')
+ cd "${_pkgbase}"
+ make DESTDIR="${pkgdir}" install
+}