summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-05-03 22:17:35 -0400
committerChris Severance2017-05-03 22:17:35 -0400
commitf9a08b064fe9536a2f4beaea0198e3c976fe2a02 (patch)
tree3f39e4c4d373e533c1202c85b075c2d83b360427
parente0efb2e8a9565622ee0e6e208d566b9237382935 (diff)
downloadaur-f9a08b064fe9536a2f4beaea0198e3c976fe2a02.tar.gz
Add symbols for stack trace
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD83
2 files changed, 48 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ca289684145..29045ef36ca6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu May 4 02:14:23 UTC 2017
pkgbase = inetutils-git
pkgdesc = A collection of common network programs
- pkgver = 1.9.4.r11.g050928b
+ pkgver = 1.9.4.r25.g3d64a8c7
pkgrel = 1
url = http://www.gnu.org/software/inetutils/
install = inetutils.install
@@ -15,13 +17,14 @@ pkgbase = inetutils-git
provides = inetutils=1.9.4
conflicts = inetutils
options = !emptydirs
+ options = !strip
backup = etc/xinetd.d/telnet
backup = etc/xinetd.d/talk
backup = etc/xinetd.d/rlogin
backup = etc/xinetd.d/rsh
backup = etc/pam.d/rlogin
backup = etc/pam.d/rsh
- source = git://git.savannah.gnu.org/inetutils.git
+ source = git://git.savannah.gnu.org/inetutils.git#commit=3d64a8c7280e7d218c4b607aa25352be1d6c4ded
source = git://git.sv.gnu.org/gnulib
source = ftpd.service::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/ftpd.service?h=packages/inetutils
source = rlogin.pam::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/rlogin.pam?h=packages/inetutils
diff --git a/PKGBUILD b/PKGBUILD
index eceae3954b1a..3bb1c6512cc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
set -u
_pkgname='inetutils'
pkgname="${_pkgname}-git"
-pkgver=1.9.4.r11.g050928b
+pkgver=1.9.4.r25.g3d64a8c7
pkgrel=1
_srcdir="${_pkgname}"
pkgdesc='A collection of common network programs'
@@ -20,14 +20,14 @@ provides=("${_pkgname}=${pkgver%%.r*}")
conflicts=("${_pkgname}")
backup=('etc/xinetd.d'/{telnet,talk,rlogin,rsh}
'etc/pam.d'/{rlogin,rsh})
-options=('!emptydirs')
+options=('!emptydirs' '!strip')
install="${_pkgname}.install"
-_verurl='http://ftp.gnu.org/gnu/inetutils/'
-_versed='inetutils-\([0-9\.]\+\)\.tar\.gz'
-_veropt='l'
+_verwatch=('http://ftp.gnu.org/gnu/inetutils/' 'inetutils-\([0-9\.]\+\)\.tar\.gz' 'l')
+source=(
+ "git://git.savannah.gnu.org/${_pkgname}.git#commit=3d64a8c7280e7d218c4b607aa25352be1d6c4ded"
+ 'git://git.sv.gnu.org/gnulib'
+) # This link must be the same as the one in bootstrap
_archlink="@@@::https://projects.archlinux.org/svntogit/packages.git/plain/trunk/@@@?h=packages/${_pkgname}"
-source=("git://git.savannah.gnu.org/${_pkgname}.git"
- 'git://git.sv.gnu.org/gnulib') # This link must be the same as the one in bootstrap
_archsource=(
'ftpd.service'
'rlogin'{.pam,@.service,.socket,.xinetd}
@@ -59,30 +59,16 @@ sha256sums=('SKIP'
#validpgpkeys=('4FBD67621082C4C502448E3B180551BAD95A3C35')
pkgver() {
+ set -u
cd "${_srcdir}"
git describe --long | sed -e "s:^${_pkgname}-::g" -e 's:_:.:g' -e 's/\([^-]*-g\)/r\1/' -e 's/-/./g'
+ set +u
}
prepare() {
set -u
cd "${_srcdir}"
ln -sf '../gnulib'
- ./bootstrap
- ./configure --prefix='/usr' --libexec='/usr/bin' \
- --localstatedir='/var' --sysconfdir='/etc' \
- --without-wrap --with-pam \
- --enable-ftp --enable-ftpd \
- --enable-telnet --enable-telnetd \
- --enable-talk --enable-talkd \
- --enable-rlogin --enable-rlogind \
- --enable-rsh --enable-rshd \
- --enable-rcp --enable-hostname --enable-dnsdomainname \
- --disable-rexec --disable-rexecd \
- --disable-tftp --disable-tftpd \
- --disable-ping --disable-ping6 \
- --disable-logger --disable-syslogd \
- --disable-inetd --disable-whois \
- --disable-uucpd --disable-ifconfig --disable-traceroute
# telnetd disconnects without banner on 90% of connections
# http://lists.gnu.org/archive/html/bug-inetutils/2015-07/msg00006.html
# http://lists.gnu.org/archive/html/bug-inetutils/2015-08/index.html
@@ -90,24 +76,55 @@ prepare() {
set +u
}
+_configure() {
+ set -u
+ cd "${_srcdir}"
+
+ if [ ! -s 'configure' ]; then
+ ./bootstrap
+ CFLAGS="${CFLAGS} -g -rdynamic" \
+ CXXFLAGS="${CXXFLAGS} -g -rdynamic" \
+ ./configure --prefix='/usr' --libexec='/usr/bin' \
+ --localstatedir='/var' --sysconfdir='/etc' \
+ --without-wrap --with-pam \
+ --enable-ftp --enable-ftpd \
+ --enable-telnet --enable-telnetd \
+ --enable-talk --enable-talkd \
+ --enable-rlogin --enable-rlogind \
+ --enable-rsh --enable-rshd \
+ --enable-rcp --enable-hostname --enable-dnsdomainname \
+ --disable-rexec --disable-rexecd \
+ --disable-tftp --disable-tftpd \
+ --disable-ping --disable-ping6 \
+ --disable-logger --disable-syslogd \
+ --disable-inetd --disable-whois \
+ --disable-uucpd --disable-ifconfig --disable-traceroute
+ sed -i -e '/INSTALL_STRIP_PROGRAM/ s: -s::g' 'Makefile'
+ fi
+ cd "${srcdir}"
+ set +u
+}
+
build() {
+ _configure
set -u
cd "${_srcdir}"
- make -s -j $(nproc)
+ local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ nice make -j "${_nproc}"
set +u
}
check() {
set -u
cd "${_srcdir}"
- make -s check
+ nice make -s -j1 check
set +u
}
package() {
set -u
cd "${_srcdir}"
- make -s DESTDIR="${pkgdir}" install
+ make -s -j1 DESTDIR="${pkgdir}" install
chmod -s "${pkgdir}/usr/bin"/{rcp,rlogin,rsh}
@@ -120,19 +137,5 @@ package() {
esac
done
set +u
- # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
- ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
- ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
- ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
- ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
- ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- # Only found in help files
- #! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
- # Only found in help files
- #! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- # Only found in help files
- #! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
}
set +u