summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvedui2015-08-17 21:10:49 +0200
committerArvedui2015-08-17 21:10:49 +0200
commitd633320a8c5ce96f73e460d18f3f000c273c4ab5 (patch)
tree4f22a5a8a30db11885f655bd545efbfc06aa8f40
downloadaur-d633320a8c5ce96f73e460d18f3f000c273c4ab5.tar.gz
Initial upload: infcloud 0.12.1-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--infcloud.install8
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..500a445a397a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = infcloud
+ pkgdesc = A Card- and WebDav web client
+ pkgver = 0.12.1
+ pkgrel = 1
+ url = http://www.inf-it.com/open-source/clients/infcloud/
+ install = infcloud.install
+ arch = any
+ license = AGPL3
+ depends = ed
+ optdepends = apache: Webserver to run infcloud
+ backup = etc/webapps/infcloud/config.js
+ source = https://www.inf-it.com/InfCloud_0.12.1.zip
+ md5sums = 151f182a0e49e977ed836955b0ef0b80
+
+pkgname = infcloud
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0363cdf9f410
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Arvedui <arvedui@posteo.de>
+# Contributor: Immae <ismael.bouya@normalesup.org>
+# Contributor: Stefan Tatschner <stefan@sevenbyte.org>
+# Contributor: Derek Leach <mail@derek.name>
+
+pkgname=infcloud
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="A Card- and WebDav web client"
+arch=('any')
+url="http://www.inf-it.com/open-source/clients/infcloud/"
+license=('AGPL3')
+depends=('ed')
+optdepends=('apache: Webserver to run infcloud')
+backup=('etc/webapps/infcloud/config.js')
+install=${pkgname}.install
+source=("https://www.inf-it.com/InfCloud_${pkgver}.zip")
+md5sums=('151f182a0e49e977ed836955b0ef0b80')
+
+package() {
+ install -d ${pkgdir}/usr/share/webapps/
+ cp -a ${srcdir}/${pkgname} ${pkgdir}/usr/share/webapps/
+
+ install -d ${pkgdir}/etc/webapps/${pkgname}
+
+ mv ${pkgdir}/usr/share/webapps/${pkgname}/config.js ${pkgdir}/etc/webapps/${pkgname}/config.js
+ ln -s /etc/webapps/${pkgname}/config.js ${pkgdir}/usr/share/webapps/${pkgname}/config.js
+
+}
diff --git a/infcloud.install b/infcloud.install
new file mode 100644
index 000000000000..5b50f80e0ded
--- /dev/null
+++ b/infcloud.install
@@ -0,0 +1,8 @@
+post_install() {
+ (cd /usr/share/webapps/infcloud/ &&
+ exec /usr/share/webapps/infcloud/cache_update.sh)
+}
+
+post_upgrade() {
+ post_install
+}