summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2015-07-17 21:45:01 +0000
committerJames Harvey2015-07-17 21:45:01 +0000
commit5a7f6f8f21293507cb5e529f4191571de1cc2562 (patch)
tree4cb95d9a924c2af032a79c879e8ecd3a9082893a
downloadaur-5a7f6f8f21293507cb5e529f4191571de1cc2562.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--rdma-ndd.service13
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5fc314b7841
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = infiniband-diags
+ pkgdesc = OpenFabrics Alliance diagnostic programs and scripts for InfiniBand subnets
+ pkgver = 1.6.5
+ pkgrel = 1
+ url = https://www.openfabrics.org/index.php/overview.html
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ license = custom:"Open Fabrics Alliance BSD"
+ depends = libibmad
+ depends = opensm
+ depends = systemd
+ depends = glib2
+ source = https://www.openfabrics.org/downloads/management/infiniband-diags-1.6.5.tar.gz
+ source = rdma-ndd.service
+ md5sums = 2a587bda5fc8287643c83363e4b6ec21
+ md5sums = 4958d94ab0760c4b5b1908d66895e118
+
+pkgname = infiniband-diags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef50a0852c26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: James Harvey <jamespharvey20@gmail.com>
+# No namcap warnings or errors
+
+pkgname=infiniband-diags
+pkgver=1.6.5
+pkgrel=1
+pkgdesc='OpenFabrics Alliance diagnostic programs and scripts for InfiniBand subnets'
+arch=('x86_64' 'i686')
+url=('https://www.openfabrics.org/index.php/overview.html')
+license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
+depends=('libibmad' 'opensm' 'systemd' 'glib2')
+source=("https://www.openfabrics.org/downloads/management/${pkgname}-${pkgver}.tar.gz"
+ 'rdma-ndd.service')
+md5sums=('2a587bda5fc8287643c83363e4b6ec21'
+ '4958d94ab0760c4b5b1908d66895e118')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ chmod 644 "${pkgdir}/etc/infiniband-diags/ibdiag.conf"
+
+ # Convert from init.d to systemd
+ rm -rf ${pkgdir}/etc/init.d
+ install -Dm644 "${srcdir}/rdma-ndd.service" "${pkgdir}/etc/systemd/system/rdma-ndd.service"
+}
diff --git a/rdma-ndd.service b/rdma-ndd.service
new file mode 100644
index 000000000000..da1deca04f25
--- /dev/null
+++ b/rdma-ndd.service
@@ -0,0 +1,13 @@
+# Freshly created, didn't find an existing rdma-ndd.service anywhere
+# Skeleton systemd service file, may need additional work such as Before/Requires/After
+
+[Unit]
+Description=Start or stop the srptools rdma-ndd daemon
+Documentation=file:///etc/infiniband-diags/ibdiag.conf
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/rdma-ndd
+
+[Install]
+WantedBy=network.target