summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Harvey2016-06-10 00:20:58 -0400
committerJames Harvey2016-06-10 00:20:58 -0400
commit01eb35ca8fd42a965c492bb4348f2d6f71d182e0 (patch)
tree73852dbe1354b3dcfbb19dd5cd4eb4562e9c89be
parent40213375e5e4becd899236865a0edf7664bed6f9 (diff)
downloadaur-01eb35ca8fd42a965c492bb4348f2d6f71d182e0.tar.gz
Upstream released 3.3-19_g67c0807 which is broken under recent GCC, temporarily grabbing 3.3-22_g4abbc60 from git. Added patch for recent GCC error still unaddressed upstream. Realized Makefile does support the libdir option as long as it's lower case, rather than the documentation's upper case reference to LIBDIR, so no longer need to manually change the Makefile.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD38
-rw-r--r--fixMisleadingIndentation.patch29
3 files changed, 59 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d02316844b1d..5218a40a7d61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
# Generated by mksrcinfo v8
-# Mon Dec 14 01:33:33 UTC 2015
+# Fri Jun 10 04:18:11 UTC 2016
pkgbase = infinipath-psm
pkgdesc = OpenFabrics Alliance Intel Performance Scaled Messaging library
pkgver = 3.3
- pkgrel = 2
+ pkgrel = 1
url = https://www.openfabrics.org/index.php/overview.html
arch = x86_64
arch = i686
license = GPL2
license = custom:"Open Fabrics Alliance BSD"
+ makedepends = git
depends = glibc
depends = libutil-linux
- source = https://www.openfabrics.org/downloads/infinipath-psm/infinipath-psm-3.3-7_g05f6f14_open.tar.gz
- md5sums = ad26294b2dc5d4769d7724db61de0c6c
+ source = git+https://github.com/01org/psm
+ source = fixMisleadingIndentation.patch
+ md5sums = SKIP
+ md5sums = fc55d52e252217c264098d590663f95d
pkgname = infinipath-psm
diff --git a/PKGBUILD b/PKGBUILD
index aeb4623619d1..b6a3378fd2d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,35 @@
# * /usr/lib/libinfinipath.so.4.0 has executable stack. That's an upstream issue.
pkgname=infinipath-psm
+_pkgname=psm
pkgver=3.3
-_pkgver_subver=7
-_pkgver_commit=g05f6f14
-pkgrel=2
+_pkgver_subver=22
+_pkgver_commit=g4abbc60
+pkgrel=1
pkgdesc='OpenFabrics Alliance Intel Performance Scaled Messaging library'
arch=('x86_64' 'i686')
-url=('https://www.openfabrics.org/index.php/overview.html')
+url='https://www.openfabrics.org/index.php/overview.html'
license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
depends=('glibc' 'libutil-linux')
-source=("https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz")
-md5sums=('ad26294b2dc5d4769d7724db61de0c6c')
+makedepends=('git')
+# Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
+source=("git+https://github.com/01org/${_pkgname}"
+ "fixMisleadingIndentation.patch")
+md5sums=('SKIP'
+ 'fc55d52e252217c264098d590663f95d')
prepare() {
- # v3.3-2_g6f42cdb uses /usr/lib64 without a proper way to override it
- # Documentation claims make install supports LIBDIR=/lib overriding the default /lib64 for x86_64 architecture, but it doesn't
- cd "${srcdir}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open"
- sed -i 's|$(INSTALL_PREFIX)/lib64|$(INSTALL_PREFIX)/lib|' Makefile
+ cd "${srcdir}/psm"
+ # Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
+ # This isn't a -git AUR package, so grab the latest known and tested commit, as of the last updating of PKGBUILD
+ git checkout 4abbc60
+ # Newer GCC catches an unpatched error upstream
+ git apply "${srcdir}/fixMisleadingIndentation.patch"
}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open"
- # infinipath-psm doesn't use configure, just make
+ cd "${srcdir}/psm"
+ # infinipath-psm doesn't use configure, just make. And make without options fails.
# And Makefile looks for "arch" environment variable to be x86_64 or i386, which is not set by default on arch linux
if [[ "${CARCH}" == 'x86_64' ]]; then
make arch="${CARCH}"
@@ -35,12 +42,13 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open"
+ cd "${srcdir}/psm"
# Again, Makefile looks for "arch" environment variable to be x86_64 or i386, which is not set by default on arch linux
+ # Also note README specifies LIBDIR option is upper case, but it's lower case libdir
if [[ "${CARCH}" == 'x86_64' ]]; then
- make arch="${CARCH}" DESTDIR="${pkgdir}" LIBDIR=/usr/lib install
+ make arch="${CARCH}" DESTDIR="${pkgdir}" libdir=/usr/lib install
elif [[ "${CARCH}" == 'i686' ]]; then
- make arch='i386' DESTDIR="${pkgdir}" LIBDIR=/usr/lib install
+ make arch='i386' DESTDIR="${pkgdir}" libdir=/usr/lib install
fi
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
diff --git a/fixMisleadingIndentation.patch b/fixMisleadingIndentation.patch
new file mode 100644
index 000000000000..ee0aefbe5de4
--- /dev/null
+++ b/fixMisleadingIndentation.patch
@@ -0,0 +1,29 @@
+From 8d6f870872eb37c1413ce6f1efff71b63d097026 Mon Sep 17 00:00:00 2001
+From: James Harvey <jamespharvey20@gmail.com>
+Date: Thu, 9 Jun 2016 23:39:33 -0400
+Subject: [PATCH] Fixed misleading indentation error
+
+---
+ psm_diags.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/psm_diags.c b/psm_diags.c
+index 3e2df9d..3714cea 100644
+--- a/psm_diags.c
++++ b/psm_diags.c
+@@ -281,10 +281,11 @@ memcpy_check_size (memcpy_fn_t fn, int *p, int *f, size_t n)
+ if (USE_MALLOC) {
+ src = psmi_malloc(PSMI_EP_NONE, UNDEFINED, size);
+ dst = psmi_malloc(PSMI_EP_NONE, UNDEFINED, size);
+- if (src == NULL || dst == NULL)
++ if (src == NULL || dst == NULL) {
+ if (src) psmi_free(src);
+ if (dst) psmi_free(dst);
+ return -1;
++ }
+ }
+ else {
+ void *src_p = NULL, *dst_p = NULL;
+--
+2.8.3
+