summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2017-02-15 00:26:51 -0500
committerJames P. Harvey2017-02-15 00:26:51 -0500
commit64955d9e8286b4057ea619c0bfd2145a458bec07 (patch)
treefd7c12bde5be9021adf96fdf44700e169b7bad12
parent01eb35ca8fd42a965c492bb4348f2d6f71d182e0 (diff)
downloadaur-64955d9e8286b4057ea619c0bfd2145a458bec07.tar.gz
Upstream's official release (3.3-19_g67c0807) still broken. Upstream's git's 3.3-22_g326b95a includes patch for recent GCC error, so removed fixMisleadingIndentation.patch, and temporarily using this until they officially release non-broken source again.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--fixMisleadingIndentation.patch29
3 files changed, 7 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5218a40a7d61..eaf68cb0bfef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jun 10 04:18:11 UTC 2016
+# Wed Feb 15 05:24:45 UTC 2017
pkgbase = infinipath-psm
pkgdesc = OpenFabrics Alliance Intel Performance Scaled Messaging library
pkgver = 3.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.openfabrics.org/index.php/overview.html
arch = x86_64
arch = i686
@@ -13,9 +13,7 @@ pkgbase = infinipath-psm
depends = glibc
depends = libutil-linux
source = git+https://github.com/01org/psm
- source = fixMisleadingIndentation.patch
md5sums = SKIP
- md5sums = fc55d52e252217c264098d590663f95d
pkgname = infinipath-psm
diff --git a/PKGBUILD b/PKGBUILD
index b6a3378fd2d2..71de82426ae2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgname=infinipath-psm
_pkgname=psm
pkgver=3.3
_pkgver_subver=22
-_pkgver_commit=g4abbc60
-pkgrel=1
+_pkgver_commit=g326b95a
+pkgrel=2
pkgdesc='OpenFabrics Alliance Intel Performance Scaled Messaging library'
arch=('x86_64' 'i686')
url='https://www.openfabrics.org/index.php/overview.html'
@@ -16,18 +16,14 @@ license=('GPL2' 'custom:"Open Fabrics Alliance BSD"')
depends=('glibc' 'libutil-linux')
makedepends=('git')
# Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
-source=("git+https://github.com/01org/${_pkgname}"
- "fixMisleadingIndentation.patch")
-md5sums=('SKIP'
- 'fc55d52e252217c264098d590663f95d')
+source=("git+https://github.com/01org/${_pkgname}")
+md5sums=('SKIP')
prepare() {
cd "${srcdir}/psm"
# Latest more-official release at "https://www.openfabrics.org/downloads/${pkgname}/${pkgname}-${pkgver}-${_pkgver_subver}_${_pkgver_commit}_open.tar.gz" is broken
# This isn't a -git AUR package, so grab the latest known and tested commit, as of the last updating of PKGBUILD
- git checkout 4abbc60
- # Newer GCC catches an unpatched error upstream
- git apply "${srcdir}/fixMisleadingIndentation.patch"
+ git checkout 326b95a
}
build() {
diff --git a/fixMisleadingIndentation.patch b/fixMisleadingIndentation.patch
deleted file mode 100644
index ee0aefbe5de4..000000000000
--- a/fixMisleadingIndentation.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 8d6f870872eb37c1413ce6f1efff71b63d097026 Mon Sep 17 00:00:00 2001
-From: James Harvey <jamespharvey20@gmail.com>
-Date: Thu, 9 Jun 2016 23:39:33 -0400
-Subject: [PATCH] Fixed misleading indentation error
-
----
- psm_diags.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/psm_diags.c b/psm_diags.c
-index 3e2df9d..3714cea 100644
---- a/psm_diags.c
-+++ b/psm_diags.c
-@@ -281,10 +281,11 @@ memcpy_check_size (memcpy_fn_t fn, int *p, int *f, size_t n)
- if (USE_MALLOC) {
- src = psmi_malloc(PSMI_EP_NONE, UNDEFINED, size);
- dst = psmi_malloc(PSMI_EP_NONE, UNDEFINED, size);
-- if (src == NULL || dst == NULL)
-+ if (src == NULL || dst == NULL) {
- if (src) psmi_free(src);
- if (dst) psmi_free(dst);
- return -1;
-+ }
- }
- else {
- void *src_p = NULL, *dst_p = NULL;
---
-2.8.3
-