summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHUANG Wei2018-03-26 10:46:07 +0800
committerHUANG Wei2018-03-26 10:46:07 +0800
commitcbf25c6e8a70e0941ebe223edc6e4796f3e6a07d (patch)
treeb726fd9ba6bf452e88f324a5372ed9ee57757574
parentf2cc453b5d318f99d995462dbbd7600ac9e47ba4 (diff)
downloadaur-cbf25c6e8a70e0941ebe223edc6e4796f3e6a07d.tar.gz
Tweak auto script
-rw-r--r--auto.ex8
1 files changed, 5 insertions, 3 deletions
diff --git a/auto.ex b/auto.ex
index 360d674f98d2..a4921aedc634 100644
--- a/auto.ex
+++ b/auto.ex
@@ -1,8 +1,8 @@
defmodule Auto do
use Tesla
- @pkg "../PKGBUILD"
- @srcinfo "../.SRCINFO"
+ @pkg "PKGBUILD"
+ @srcinfo ".SRCINFO"
@map %{
"Linux Binaries (32-bit)" => ["i686"],
@@ -78,9 +78,11 @@ package() {
end
def process(content) do
+ IO.puts "Working directory #{System.cwd!()}"
File.write!(@pkg, content)
- System.cmd("makepkg", ["--printsrcinfo", ">", "#{@srcinfo}"])
+ {output, _code} = System.cmd("makepkg", ["--printsrcinfo"])
+ File.write(@srcinfo, output)
end
def run() do